0

I recently got my hands on a Canon FT QL and I think the light meter might be broken, but I'm not 100% sure if that's the case and, if it is, exactly what is wrong with it.

Behaviour: so, when I don't put a battery on the camera it's stack on de lowest position (as it should) and it changes it's resting position depending on the shutter speed and ISO, now when I put the battery on it's always in an overexposed position (up, past the circle) no matter how low the ISO, shutter speed and aperture. Now the truth is that sometimes it seems to work, but it's on extremely rare ocations and it looks to be completely aleatory (unless I'm doing something wrong?) and also the needle does move with the change of light but how much it moves it's insignificant compared to the light differences I expose the camera to. I also tested this with two different batteries I have, they are both 1.5V replacement batteries but one is really discharged(my multimeter says 1V) and the other is brand new, but nothing changes with this.

So, up to now my main theory is that the light sensor of the circuit is faulty and that is why it rarely work and why it barely moves with such a low sensitivity, but I'm here mostly to see if this theory is wrong and what else could be the reason.

  • Where does the needle move when doing a battery check (film speed 21/100, shutter speed X, move battery check switch to "C" position)? – cmuseum Feb 5 at 21:41
  • Thanks for commenting, sorry for not replying, I went m.i.a, in the meantime I realised what was happening, I will answer my own question now. – Martín P Feb 28 at 0:48
0

After more testing on my camera I realised what happened (although I can't completely tell why it happens). So what happens basically is that a new 1.5V battery is too much, period, so that's why it shows overexposed always and the lower voltage battery is fine so it works okey. Now what was happening that led me to believe that the meter works "randomly" was that when I used the meter with the new battery the circuit stayed "overcharged" for quite a long time, even if I switched batteries. And if I did the opposite, the circuit remained okey for a long time, even if I switched for the new, fully charged battery, which again contributed to a feeling of randomness on the behavior.

0

These cameras were designed for a 1.3v mercury battery. Wein makes a MRB625 replacement. They are available from B&H online. I use one and it works great in my FT QL.

  • Also, some people have had good success converting various cameras to 1.5V cells by putting a germanium or schottky diode (NOT: An LED, a plain silicon diode, or a vacuum tube diode ;) ) in series with the battery holder.... – rackandboneman Sep 17 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.