I have a Nikon D-700 I downloaded the firmware version 1.04/1.03 to a formatted card with the .bin file but when I go to the menu to update, I have the yes button and I can see the previous and newer firmware versions but the menu will not allow me to select it. I am stuck in the yes bar and it will not go any further. Is the camera damaged or is there another way to update this?

  • Here are some good instructions: – WayneF Jan 17 '19 at 17:24
  • Just wondered if you actually formatted the card on the camera first and not via a computer.Card needs format via camera only.Then add the bin file. – jomico Jan 27 '19 at 12:53
  • I formatted by camera then copied the .bin file and I tried formatting on the computer (FAT32) and neither method worked. – James Gilman Jan 28 '19 at 16:34
  • The right hand side selector does work for other menu options, just not in the firmware upgrade options – James Gilman Jan 28 '19 at 18:02

You should not be pressing the selector button. It's asking you to press the OK button, and that is at the bottom left.

enter image description here

| improve this answer | |
  • You have solved my mystery and uncovered what a knucklehead I am. – James Gilman Jan 29 '19 at 23:37
  • Formatting cards works the same way, you can click the select until the last step, then you have to click OK. Prevents you from mindlessly clicking and reformatting a card. – MikeW Jan 30 '19 at 2:04

enter image description hereThat's correct. It's showing you the current and new firmware.

[!Here is what my screen looks like. When I depress the select button, nothing happens. I can't select the version, It is stuck at yes and won't go any further.

There is no selection other than YES, do the upgrade.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.