1

I am using darktable 2.6 on Windows 10. This problem started recently.

After importing a raw image, when I change anything (exposure, contrast, etc), the preview temporarily resembles the jpg photo. If I zoom in and out, the image goes back to raw. This is very strange as I cannot see what is the effect of whatever module I change.

After a system restore, the program went back to how it was before (without the problem). But the problem returned, and I still haven't figured what it is.

Not only are the colors very different, the histogram varies without anything being changed. See images.

The contrast block changes the histogram inconsistently. And again the image color is wrong.

first histogram

second histogram

third histogram

  • 2
    Nit: you are never looking at the raw image. You are always looking at a rendering. How that render is generated and cached is a different question, of course. – user31502 Jan 15 at 14:58
  • 1
    I think this is more of a bug report than a question. For what it's worth, I can't reproduce this behavior on the Linux version. – junkyardsparkle Feb 17 at 23:42
  • FWIW, I'm getting the same issue - same setup as the OP (2.6 and Win 10). Am using half-RAW preview rather than the JPEG, as well. – user82573 Mar 10 at 2:41
1

This question describes what may be a couple different problems:

when I change anything (exposure, contrast, etc) temporarily the preview I get from darkroom is what resembles to the jpg photo

  • This may be related to the setting, GUI Options | "don't use embedded preview JPEG but half-size raw", which talberg describes. Make sure it is enabled.

  • It may be associated with OpenCL settings (under "core options"). GPU accelerated tasks sometimes have unusual behavior.

  • It may be a bug in the Windows version, since junkyardsparkle cannot reproduce the behavior on Linux. (Neither can I.)

The contrast block changes the histogram inconsistently. And again the image color is wrong.

  • The inconsistent histogram and "wrong" colors may be associated color-space conversions. The working color space that darktable uses cannot be changed. According to darktable: Color management:

    between input color profile and output color profile – Image is in Lab format. This is a very huge universal color space which covers all colors visible to the human eye (and even more). As darktable processes images in 4x32-bit floating point buffers, we can handle the Lab color space without risking banding or tonal breaks.

    Color-space conversions can lead to unexpected behaviors in the histogram that are associated with how colors, especially those that are out of gamut, are remapped. You can try enabling core options | "always use LittleCMS 2 to apply output color profile". Then in the "output color profile" module, try changing "output intent" to an option that seems to work well for your image.

    To illustrate, here are histograms from RawTherapee when shifting each color curve to the right when the working and output color spaces do not match. Note the changes in the unshifted curves.

    Histograms: Mismatched Color Spaces

    Here are the histograms for the same operations when the colors spaces do match. Note that the unshifted curves remain unchanged.

    Histograms: Matched Color Spaces

0

Darktable has a couple options that influence which image is displayed when. Check your settings, in particular the one that says "don't use embedded preview JPEG but half-size raw" under "GUI options".

  • I have done that, but still get what it looks like the JPEG image preview and then if I zoom in and out again back with the RAW – Henrique Silva Jan 18 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.