I've upgraded K-S1 camera firmware to latest version, played with some settings and reset them to defaults.
For some reasons, manual (K) lenses aren't accepted anymore. Modern auto-focus lenses work fine but for my old lenses, the camera doesn't show focal length setting when turned on. Display shows flashing F-- and I can't take pictures in any mode.


1 Answer 1


To use manual (K) lenses, Using Aperture Ring in menu C4 - 26 needs to be enabled (not enabled by default) - check user's manual, p. 85 - Setting the Focal Length.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.