My D5300 with 18-140mm lens is having problem "Press Shutter Release Button Again"...as error message pops ups in AF mode....but in manual focus mode...the error is not there, but images are over-exposed most of the time. The strange thing is that, with the same body and nikon 200-500mm lens there's no problem..it's perfeclty fine in both mode...what can be the issue??

It works fine with nikon 200-500mm lens, and why not on 18-140mm lens?

Check my images with nikon 200-500mm lens on the same body here https://www.instagram.com/_bird_snaps/

  • \$\begingroup\$ It works fine with nikon 200-500mm lens, and why not on 18-140mm lens? \$\endgroup\$
    – Sayan Bera
    Commented Nov 4, 2018 at 13:41

1 Answer 1


If it works fine with the 200-500mm, then the problem is either:

  1. with the 18-140mm lens. Or,

  2. with the combination of the interaction between your particular camera and your 18-140mm lens.

The way to absolutely diagnose it is to try your 18-140mm on multiple different camera bodies, and to try multiple other lenses on your D5300 body. If the problem occurs when you lens is mounted to different bodies, then the problem is with your lens. And conversely, if the problem occurs with other lenses mounted on your camera, then the camera body is the likely suspect. Unfortunately, most of us don't have several camera bodies and lenses we can interchange to do this diagnosis. So you'll probably have to have them serviced.

In your description, you said that even if the error doesn't appear, with your 18-140mm lens the images appear overexposed. This sounds like your lens has a sticky, bent, or otherwise suffers from high friction somewhere in the aperture or aperture linkage system, as though the aperture does return to its spring-loaded stopped-down position (or at least, its setting less than fully open). That's why images are still overexposed.

Unless you're familiar and comfortable with lens repair, there's not much you do, other than have the lens serviced or repaired.

  • \$\begingroup\$ The clunky mechanical aperture control left over from the 1950s (and left in the dust my multiple other manufacturers in the 1980s) strikes again! \$\endgroup\$
    – Michael C
    Commented Nov 5, 2018 at 20:30
  • 1
    \$\begingroup\$ @MichaelClark Oh yeah. I don't know if Nikon regrets it, but many Nikon shooters sure do. At least they are (verrry slowly) starting to incorporate electronic aperture control as they refresh lenses (mostly from the high end of the line downwards. And of course, hopefully their Z mount gets fast traction... \$\endgroup\$
    – scottbb
    Commented Nov 5, 2018 at 20:40
  • \$\begingroup\$ I'm really confused... \$\endgroup\$
    – Sayan Bera
    Commented Nov 7, 2018 at 5:20
  • \$\begingroup\$ I tried with a kit lens(18-55mm) of another person, the same error pops up. Another problem I noticed was, while attaching the 18-140mm lens to the body, it's bit hard, not attaching smoothly as earlier. But on 200-500mm it attaches smoothly....so really confused....I'll take to service center. \$\endgroup\$
    – Sayan Bera
    Commented Nov 8, 2018 at 5:29
  • \$\begingroup\$ @SayanBera if the 18-140mm is difficult to attach, then that lens is probably the problem. It sounds like the aperture linkage lever is slightly bent, or maybe there's a lot of internal friction in the aperture mechanism. Do not attach it to your camera any more. If the lever is slightly bent, it's possible for the lens to become stuck to your camera, making it unremovable by you. Absolutely, you need to have the lens serviced. \$\endgroup\$
    – scottbb
    Commented Nov 8, 2018 at 5:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.