1

My D3300 shows the “shutter error” and will not record any pictures and it will also not show any live feed. When I have it in manual mode, I can see the shutter flip easily with no issues and everything looks to be in place and mechanically working. Sometimes it will take a picture but it is just a fuzzy dark purple image (photo below). I know it’s a $300-$400 fix at my local camera shop and I don’t want to pay that, that’s more than the camera. Could it be that the shutter is moving too slow? Any advice? enter image description hereenter image description here

  • 3
    Are you seeing the shutter move or seeing the mirror flip? – mattdm Oct 25 '18 at 14:58
  • Technically, your message is not saying you have a shutter error. It is asking you to release the shutter in an attempt to resolve an undefined error. – Michael C Oct 25 '18 at 18:31
  • have you managed to fix your camera ? I have exact same issue, those photos in between "Shutter error" that I can take are exactly like the thing you posted. It actually happened for the second time ... I have dropped the camera twice, first time I took the camera to service, I was in Poland back then, and they fixed that for me quickly for 270PLN (~70 USD), now it happened to me again, Im in Australia and I talked to Nikon - they basically said it will cost heaps, pay per hour to the technician + parts and they straight away offered discount for a new camera ... so I am looking for an alterna – James May 29 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.