0

I did an update on my Nikon d5300 and for some reason during the install the camera turned off by itself and the after that I gave it some minutes and then turn it off from the switch and back on but the screen won’t light up, I can’t see anything , it focuses! I can move the focus point around ,I can see all my settings on the viewfinder, I can play with the aperture , iso and shoterspeed and it all shows on the viewfinder, even the pop up flash works , and the focus assist light, and when I press the shutter button it takes pictures but it won’t saved them to the sd card and every now and then I get the msg error on the view finder and the green light on my camera keeps flashing , I tried connecting my camera to my laptop but it won’t be recognized ,enter image description here

  • What was the charge state of the camera's battery when you started the update? – Michael C Oct 21 '18 at 18:35
  • It was fully charged , it had a camera grip on it with 2 fresh fully charged batteries cuz I was about to go for a shoot, do you have any suggestions how to get it working again? It always worked fine I never had issues with it or accidents , i never dropped it or anything I got it new 2 years ago it was just after the update that the screen didn’t work. – Edgar coronado Oct 21 '18 at 19:17
  • Did you try with a different SD card? – xenoid Oct 21 '18 at 20:42
  • 1
    I avoid updating firmware with a grip attached to the camera. It' s just one more potential point of failure between the battery and the camera. I have had a grip which, after a hard bump, occasionally flexed enough to momentarily lose contact with the power connection just long enough to lose everything in the buffer that was not yet written to the card. If that were to happen during a firmware update, it could brick your camera. That doesn't help you now, though. – Michael C Oct 21 '18 at 21:40
4

For whatever reason, the update seems to have caused the issue. It's possible the update file was corrupted somewhere in the chain between the server from which it was downloaded, your computer, the memory card to which it was loaded, and the camera's internal memory. Or it is possible the camera had a power glitch during the update that corrupted the firmware as it was written to your camera's flash memory.

Without being able to see the screen, it will be almost impossible to try and run the firmware update again unless you have a working example D5300 to use as a reference as you go through the menu. A well written instruction manual (I think Nikon calls them Reference Manual as the User Manual is much shorter and less detailed) could also guide you through updating the firmware "blind."

If you do try, download the update file again, preferably from a different server than you did before. Use whatever tools you have available to insure the file integrity of the download before and after transferring it to a memory card to be placed in the camera. Remove the grip and place a fully charged battery directly in the camera. Use a different memory card.

If there's an option to update the firmware via a USB connection to a computer rather than via a memory card, you can try that and you should be able to follow the instructions on the computer's screen.

If that doesn't work, you probably need to send it to a Nikon Service Center. They'll probably need to reflash the memory on the camera's motherboard that contains the firmware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.