I switched to Linux and started using Darktable as my RAW processor. It is great and I love all of its functions. Lately I've tried to do some HDR shots and I noticed that the parts which are blown out have a pink hue. I tried everything: changing input profile and output profile, tone mapping etc. but couldn't get rid of that pink without ruining the rest of the picture. I tried RawTherapy and when I open the image it looks perfect, there's no pink hue in the sky, it just looks like it is supposed to look. See the Sample pictures (First one is Darktable, second one is RawTherapy - no edits at all!)

I really want to continue using Darktable because I like its functions and workflow a lot better so I want to fix this problem. Does anybody have an idea what is wrong?

Thanks in advance

There is another question that is quite similar (Why are my highlights purple?) but it doesn't explain why RawTherapy shows the right colors whereas Darktable has that problem and how I could fix it.

Sample Darktable Sample RawTherapy

  • 5
    \$\begingroup\$ Related: Why are my highlights purple? \$\endgroup\$
    – mattdm
    Commented Aug 17, 2018 at 16:22
  • \$\begingroup\$ Can you link to your RAW file so I can play with it a bit? \$\endgroup\$
    – mattdm
    Commented Aug 17, 2018 at 16:29
  • \$\begingroup\$ Sure, how can I do that? \$\endgroup\$ Commented Aug 17, 2018 at 16:34
  • \$\begingroup\$ Unfortunately no file storage for things like that here, so put on some hosting site and link? \$\endgroup\$
    – mattdm
    Commented Aug 17, 2018 at 16:35
  • \$\begingroup\$ Here it is. I hope it works. ufile.io/jteix Thanks again \$\endgroup\$ Commented Aug 17, 2018 at 16:38

1 Answer 1


The basic problem is that the raw sensor data probably is tilted that way after adjusting for white balance. So, the blown highlights end up with a pink/magenta cast. The solution is in the Highlight Reconstruction module, and in specific, the clipping setting — you tell Darktable to just discard the magenta highlight color information.

It can also be helpful to turn on one of the reconstruction modes, which help retain some detail rather than just clipping everything to flat gray. Here, I used Reconstruct in LCh, and turned the clipping way down:

enter image description here

... and voila! — goodbye, pink.

You can read more on this module in the darktable documentation. The module also has a blending option, which can be used to apply the feature to only a part of the image. I don't think that's necessary in this case, but it might be useful in others. (Read more on that in the manual, too, here.)

  • \$\begingroup\$ This is just amazing. Thank you so much for the fast and detailed explanation. \$\endgroup\$ Commented Aug 17, 2018 at 17:23
  • 1
    \$\begingroup\$ Just be careful when lowering the clipping threshold to <1 that you're not clipping away any faint areas of almost clipping color that you want to keep... In that RawTherapee version, for example, note the missing blue in the upper-right corner... \$\endgroup\$ Commented Aug 17, 2018 at 21:20
  • \$\begingroup\$ Good point @junkyardsparkle. I don't think it matters much in this particular image but good to keep in mind in general. \$\endgroup\$
    – mattdm
    Commented Aug 17, 2018 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.