A message from our CEO about the future of Stack Overflow and Stack Exchange. Read now.
    Question Protected by Community
3 edited title
| link

How to troubleshoot a Nikon d5100 won'tD5100 that will not autofocus at all?

2 edited tags
| link
1
source | link

Nikon d5100 won't autofocus at all

A good friend of mine has a d5100, which was working perfectly fine yesterday. Today, however, it refuses to autofocus at all - it makes no effort to move the focusing ring etc.

I have tried everything I know, from the obvious (making sure it's set to auto, not manual focus), to the less obvious (changing AF-L settings, trying Live View), to the downright desperate (trying every mode, random setting, and a menu reset) among others. I have also tried changing lenses, but the problem is the same.

This points to the problem almost certainly being in the camera body. The lens contacts are clean, the lenses were correctly fitted and it was bright enough to autofocus.

Currently I have no ideas other than a faulty shutter release button, broken circuitry (unlikely), or some bizzare instant-burnout of the lenses' AF motors.

Please, does anybody know anything about this? Thanks in advance, I will be eternally grateful (and owe you a beer/wine/tea/soft beverage if we ever meet!).