Incense

by Bart Arondson

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I'm unable to edit some of my tripod and shutter release shots in GIMP 2.8.10. It only seems to affect the photos taken in bulb (full manual shutter timing) mode, where I have exposure times anywhere between 30 seconds and 8 minutes.

It isn't the actual images that are causing the problem, because if I strip the EXIF data from the photo, it opens fine with Gimp. However, I really don't want to strip the EXIF data, especially the exposure time tag, which could be the source of the problem.

How can I open these images in GIMP without all (or even some) of the meta data on them?

share|improve this question
    
Is there an error message? What version of Gimp? –  mattdm Aug 2 at 14:08
2  
Not a solution, but a workaround: strip the metadata from a copy, edit, and then use exiftool to copy the metadata from your original. (You probably want a backup of the original in any case.) –  mattdm Aug 2 at 14:09
    
@mattdm: Oh yeah, should have mentioned that. It's the latest stable version of Gimp (2.8.10), and I'm not getting an error, it just sits with the "Opening '<file>'" status bar at 0. –  MBraedley Aug 2 at 14:11
    
Try launching gimp from the command line and opening the file. See if there's any output on the console that might provide a clue as to what's happening. –  Michael Kjörling Aug 2 at 15:38
    
@MichaelKjörling: no, I'm not seeing anything. I'm on Windows, and the control returns to the command line when I open Gimp. Even if I use Gimp-console, there's nothing different between launching it without the file and with. –  MBraedley Aug 2 at 15:46

2 Answers 2

up vote 6 down vote accepted

This would seem to be this acknowledged bug in GIMP; that bug has itself has been closed as a duplicate of this bug, which has been fixed in the development ("master") builds of GIMP by a complete rewrite of the metadata handling. The question I'd more be asking here is why Partha's rebuild mentioned in MBraedley's answer fixes the problem, rather than why it's not working in the official builds.

share|improve this answer
    
Yeah, those bug reports definitely seem to cover my issue. So maybe it's all shots taken with the bulb setting (of which I have 0)? –  MBraedley Aug 2 at 20:46
    
Disclaimer: I'm not a GIMP developer, so don't take my word for any of this (I am a software developer though, so am used to reading software bug reports!). I think all we can say from this side of the fence is that there is a certain structure which is written into the EXIF data of some bulb mode JPEGs (it would be vaguely interested to know which camera you're using) which causes GIMP 2.8 to barf. The only people who will be able to tell you if that problematic structure is written into every bulb mode JPEG is your camera manufacturer - although with enough data points, we can guess! –  Philip Kendall Aug 2 at 21:08

This recompiled/repacked version of Gimp by Partha allows me to open the files without a problem. The "Edit with GIMP" context menu item doesn't work 100% out of the box, and the interface theme is different by default, but does include a bunch of useful plugins not distributed with stock Gimp.

Still don't know why the stock version of Gimp won't handle it, though.

share|improve this answer
    
I've seen Partha's build bypass a bug before. I'd suggest using the contact form and ask Partha themselves about the issue. They may have even deliberately patched it. BTW, the downside of Partha's build is that you can't use 32-bit plugins. Or at least, you couldn't last I checked. So maybe the lack of 32-bit code is the issue. –  trlkly Aug 3 at 3:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.