Alley in Pisa, Italy

by Lars Kotthoff

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I'm processing a batch of photos in Lightroom 3.2. They are all of a Fall nature, so I want to apply the "Fall" keyword to the lot (31 of them). When I select all of them (click, shift+click), then enter the keyword in the Keywording box (in Library view), "Fall" is only applied to the first image that I selected, not all of them.

I seem to recall this works in Bridge. Is there a different way to go about it in Lightroom?

share|improve this question
    
Have you got"Auto sync" enabled? –  Rowland Shaw Nov 21 '10 at 11:40

5 Answers 5

up vote 8 down vote accepted

When bulk tagging, you need to make sure you are in library mode, AND that you are selecting photos from the main grid, not the film strip. I think this is a bug in LR3, however if you select multiple photos from the film strip, and then try to tag them, the tagging does not always take. It usually applies to the first photo selected, but not the rest. There seems to be a threshold to this...if you select only a few images in the film strip, it may work, but more than say 8-10, and it usually does not.

Manual Tagging in Library

alt text

When selecting multiple images from the main grid in Library mode, bulk tagging works fine. Just remember to hit the enter (return) key in the keyword box before moving on to make certain the update is actually applied to all of the selected images. In my experience, bulk tagging in the grid has always worked, while bulk tagging from the film strip has been sketchy at best, and generally never seems to work.

Painting Tags in Library

alt text

An alternative mode of tagging is to use the library painter. It is a small spray paint can icon next to the view mode icons below the grid in Library mode. Selecting this, it defaults to Keywords. Just enter the keywords you want to add, then click on the images you wish to add the keywords to. You can either click each image individually, or click and grad the spray can over multiple images in a continuous stream to "paint" on the new keywords. Click the icon below the grid again to disable paint mode.

share|improve this answer
    
Thanks for the pointers on the grid view vs filmstrip view. I was able to get the tagging done in short order due to your advice. –  Grant Palin Dec 9 '10 at 6:47
    
Glad to be of service. :) –  jrista Dec 9 '10 at 17:40

No, it works like you say. Are you sure you have selected all the photos? When you select multiple photos and you add a keyword, Lightroom asks you if you want to apply the setting to all the selected photos.

share|improve this answer

You can use "Painting" feature and "paint" keywords on the photos. To enable this function you can go to menu Metadata->Enable Painting (CTRL+ALT+K) or click on spray icon on the tab bellow list of pictures when in Library module, choose that you want to paint with keywords type keyword and start painting:

alt text

share|improve this answer

When I do this in Loupe view, the keyword is only applied to the photo that is visible, even if multiple photos are selected in the strip at the bottom.

If I do this in Grid view, then the keyword is applied to all the photos in the grid.

Enabling Auto Sync is for having settings you make in Develop mode applied to all selected photos. I don't know whether it affects keywording in Loupe view. (I'm away from my desk so I can't check right now.)

share|improve this answer

The solution for me (LR3.5) was simply closing LR (and letting it back up the catalog settings), then re-opening it. Works fine then.

share|improve this answer
1  
This answer does not appear to be relevant to the question. Are you saying this is a bug in the UI which you have also experienced? From the other answers, that sounds like a possibility, but I'm not sure if that's what you mean. –  mattdm Dec 1 '11 at 9:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.