Alley in Pisa, Italy

by Lars Kotthoff

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

Last night I tried to get some club shots with my 60D (with the 16-35 2.8L lens) at ISO 1600.

I had about ¹⁄₁₅ — ¹⁄₂₀ seconds at f/2.8, all in Av mode.

When I raised the pop-up flash, I hoped that the camera would decrease the time to ¹⁄₆₀ or ¹⁄₂₅₀ to freeze some of the motion, but the timing remained as it there would be no flash. I had to switch to "M" to get the desired result. I know from my 550D that on that camera there is a setting that automatically switches the timing as soon as one raises the flash. To make a long story short, is there a camera fault or did I miss a setting?

share|improve this question

marked as duplicate by mattdm, Caleb, John Cavan Jan 3 at 4:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    

2 Answers 2

up vote 2 down vote accepted

This behavior is perfectly normal for a Canon 60D, and most other Canon EOS bodies. When you select Av Mode with E-TTL in lower light environments, the camera assumes you want to expose the entire scene correctly for the ambient light and then use the flash to illuminate your subject in the foreground.

If you wish to disable this slow sync feature, use custom function C.Fn. I-7 and select either option 1 (for Tv of 1/60-1/250 sec) or 2 (for Tv of 1/250 sec.). What you descibe in your question is the result of the default option 0, which will allow shutter speeds between 30 sec and 1/250 sec.

See also this answer to Why is flash TTL metering independent from ambient light metering?

share|improve this answer

This is how Canon DSLRs work, in Av and Tv modes the camera exposes for the ambient light and only uses the flash for fill.

To use the flash as the main light source you have to use full auto or P mode.

or - the best options is to do what you did and use M mode, in manual mode with the built in flash or an external flash in TTL mode you can use the shutter speed to decide how much of the ambient light you want to include and the camera will set the flash power accordingly.

By the way, I have a 550D and it works exactly like that too, it does not change shutter speed when I use a flash in Av mode

share|improve this answer
    
In the 60 D one needs to select in the custom menu the Fn I and sellect #7 flash sync speed in Av.If "0" is selected the camera will use the ambient light. only 1&2 let you select fixed shutter speeds –  user25047 Jan 1 at 16:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.