Time to be with your loved ones

Time to be with loved ones

by sat

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I can't update the firmware of my OM-D M5 to the latest release 1.7. That's what I tried:

  1. Start the firmware update tool (Ver 1.06 on OSX Mavericks),
  2. Connect the camera to a USB port of my Mac and turn it on
  3. The camera displays a "USB" menu. Select "Storage" and press OK
  4. Screen shows "one moment", then goes blank
  5. On the Mac, Aperture starts and wants to import images
  6. Switch back to the firmware update tool and click "Next"
  7. After a while, it shows current version 1.6, newer version 1.7 for the body
  8. Make sure that the "body" line is selected and click "update", and confirm twice
  9. "Updating firmware" is shown on the computer for a while.
  10. Finally, it says that the camera screen should display an image with rotating arrows and two "forbidden" signs, which indicates that the firmware is being updated.

However the camera screen stays blank. I waited several minutes, no change. If I disconnect the camera, turn it off and on again, and check the firmware version, it is still 1.6.

N.B., the same procedure worked correctly when updating the firmware of two different lenses.

How can I update the firmware?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.