Open

by damned truths

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

My 3 Years old D90 back LED keep blinking and it is causing the battery to discharge completely. As far as i understood the LED is supposed to blink few times to detect the memory card and then it should stop. Any clue as to what needs to be done.

share|improve this question
    
Have you tried this: dpreview.com/forums/post/37622904 –  subsub Sep 12 '13 at 10:06
    
I have done almost all this things (not exactly in the sequence as mentioned here though but still tried almost every combination ) .. once it seems to be working but later on the problem again started. –  user2720864 Sep 12 '13 at 10:26
    
Can you explain a little further what you have done and in what conditions the blinking happens and stops? –  mattdm Sep 12 '13 at 13:39
    
I found in the blog that people are claiming sometimes if you pull the power button to the lightbulb slot and release it suddenly so that it switch back to the off position solves the problem. I did exactly that and it seems to have really stopped for sometime. Bug again it started within couple of days. as @Michael Clark mentioned in his answer. other than this I've tried using different battery and SD card but in vain, what else I could have done? –  user2720864 Sep 12 '13 at 19:48

1 Answer 1

This is a known issue concerning the D90, and at least the D70 as well, that has been discussed at length on several forums. The problem usually seems to be with the on/off switch.

Many users have reported that moving the power switch all the way over to the lightbulb position for lighting the top-of-camera LED display and pulling their finger back and letting the spring loaded switch flick back to off solved the problem for them. This seemed to work more often when the user allowed for the possibility dirt or dust had been able to make its way into the switch.

Others have used a more methodical approach:

  1. Turn camera off
  2. Remove SD card (SD card remains out until step #11)
  3. Remove battery
  4. Turn camera on (without battery)
  5. Turn camera off (without battery)
  6. Replace battery in camera
  7. Turn camera on
  8. Try two-button reset (no visual indication this worked)
  9. Use menus to reset custom settings (see #8)
  10. Turn camera off
  11. Replace SD card
  12. Turn camera on

Some have reported the lens must also be removed for this to work. It seems that usually it is a power switch issue, but if the contacts for the SD card or lens are loose the camera will blink on and off each time it thinks either the SD card or the battery is removed or replaced.

Others have suggested that inserting a freshly charged battery immediately after removing it from the charger sends too much voltage to the Main Power IC Board in the camera and damages it. Waiting a few minutes after removing a fully charged battery from the charger is suggested as a preventative measure.

If you google Nikon Green Light of Death, you can see many more links to forums where this has been discussed.

If neither of these methods solve your problem, it is probably time to consider sending it to an authorized Nikon Service Center for a repair assessment. If the cost of repairing it is a significant percentage of the value of the camera, it may be time to consider replacing it instead. Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.