Incense

by Bart Arondson

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I covered an event today with my Canon 7D and YN568EX when all of a sudden the flash changed from manual to E-TTL mode. I tried switching it back to manual using the in camera flash menu and speedlight mode button but that proved ineffective; It goes back to E-TTL mode every time I try to change it to manual. In addition, it won't enter manual mode even when the flash is not on the camera's hot shoe. Other than that, the flash is working fine.

Has anyone experienced this issue with theirs? What can I do about this?

share|improve this question
    
I also faced same problem today :/ –  user21863 Aug 28 '13 at 18:13
    
I got exactly the same Issue, but with some more trouble-shootings. The 568 Ex even not on the hotshoe is really hard to configure. Need to push for 2-3 seconds on buttons to operate. ETTL II mode is the only running on the 5D2 when attached and the Zoom stays on 14mm and can't be changed even if not on the hotshoe. Furthermore, after shooting 2 or 3 times, the Pilot led turns green and the flash turns off saying there aren't any batteries left (of course I tried several batteries).. Did you find any solution? Thx (skuz 4 my bad english, I'm a "froggie" ;-) –  user21909 Aug 30 '13 at 13:55
    
wow.. you must have a really bad copy @Mikael Crozat. Mine was good at first. Only went bad after 7 months. No solution found yet.. planning to buy an original canon flash. I don't trust 3rd party flashes anymore. –  ides Sep 2 '13 at 15:21
    
@MikaelCrozat - sorry but I didn't find any solution for this. I just bought a Phottix Mitros flash as a replacement. –  ides Oct 17 '13 at 8:51

3 Answers 3

It sounds like something in the flash unit has gotten stuck in E-TTL mode. The only thing I might suggest is removing the batteries for a few minutes to see if that allows the unit to reset. Also try setting all the options to the original default settings. If that doesn't work you may have to decide whether to try and get it repaired or just replace it. It would probably cost less to just replace it.

share|improve this answer
    
argghh.. nothing works... I guess it's better to just buy a new flash.. –  ides Jun 24 '13 at 12:35

Just had the same issue with it flashing at 14mm. Turns out the diffuser was not pushed back in far enough until it clicks. All sorted now!

share|improve this answer
    
Good for you Jon. I also got the same issue before. It took me a week before I found out about the diffuser. Now I only use my YN as a slave. –  ides Oct 17 '13 at 8:52
    
I have a 5dIII and of for the life of me I couldn't figure out why the zoom was sticking at 14mm, when I've got my 35mm lens attached. Thank you so much for the hint about putting the diffuser back in. I guess the diffuser automatically shifts the zoom to 14mm? Why? By the way, the way I fixed the battery issue was putting electrical tape over the battery door. Wit time the teeth on the door wear out. –  user22979 Oct 31 '13 at 4:35

I had this same problem, and I needed to go into my camera's speedlight control / flash function menu to alter the flash settings. This is REQUIRED if you are using the Yongnuo YN622 transceivers, and if you are using two or more, then you need to activate the Flash Group to A:B or A:B:C so that you can control them separately (obviously putting each of the YN622's on its own group).

share|improve this answer

protected by Community Oct 31 '13 at 9:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.