Westminster fountain at sunset

by Jorge Córdoba

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I am using LR/Transporter to export metadata from Lightroom to a .csv file. For the most part this works flawlessly. However, if I have a comma in the Caption field anything after that comma gets bumped to the next column.

For the Keywords field their is a modification option that coverts commas to a semicolon or other character. To do that you do this:

{keywordTags[;]}

I attempted using the a modification similar to that for the caption:

{caption[;]}

Unfortunately this does not work. Is there something else I can do to preserve the normal use of commas in the caption field?

My goal is to be able to export the contents of night fields from Lightroom to a .csv file and retain the integrity of the data.

Thank you.

share|improve this question
    
Sounds like an escaping problem with LR/Transporter. –  Dan Wolfgang Apr 19 '13 at 1:26
    
Hi Dan, you are correct. I just need to know how to solve that problem. –  fmz Apr 19 '13 at 2:01
2  
Have you filed a bug with them? Sounds like they have one. A CSV field with a comma should be quoted. While CSV doesn't have a formal standard, there are certain generally accepted rules and this is one of them. –  John Cavan Apr 19 '13 at 2:17
    
I have tried contacting Timothy Armes, the developer, but haven't heard back. –  fmz Apr 19 '13 at 2:20
1  
@dpollitt - Hard to say... Photographers may want to do this, so in that sense it belongs. However, that the best answer is "it's a bug" in a comment implies that it's DOA for this site. –  John Cavan Apr 19 '13 at 4:11

3 Answers 3

Instead of creating a Comma Separated file LR/Transporter will output a Tab Delimited file which will preserve your commas and make importing the data much cleaner.

If you really need a CSV file you can easily make or use a tool to do the conversion from Tabs to Commas that can preserve the commas.

Here is a good post about the trouble with the CSV format and workarounds for different use-cases. http://stackoverflow.com/q/4025831/210570

P.S. Using the Lightroom 5 Beta, LR/Transporter is not adding carrige returns at the end of each photos metadata. To get around this I am using a text editor to replace the "\n" with a carriage return so that Excel may properly import the file.

The Head: Caption{tab}Keywords\n

The text for each photo: {caption}{tab}{keywordTagsForExport}\n

share|improve this answer
up vote 2 down vote accepted

My apologies to Dave, who provided a solid response to the question, however, not satisfied with a work-around, I continued searching. Thanks to some very kind advice from Rob Cole I was led to find: ListView by John Beardsworth. This is the Swiss Army Knife of Metadata export. My only regret is that I didn't find it sooner. It can export any and all metadata to Excel or .csv. Excellent solution.

share|improve this answer

A proper export to CSV should wrap any content with a , within it in a string identifier or string wrapper. Check if there is an option to add string wrappers. Normally they would be double quotes ("), but often in good CSV output engines, they will allow you to specify the value to use. If you can't find such an option, then it is likely a bug that will need to be fixed by the developer as there is no way to tell which commas are content and which are separators after the fact (unless you are able to change the separator to something that isn't , (at which point it technically isn't a CSV file anymore.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.