Serene Life

by garik

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I keep getting an error message on my canon 1100d, when taking photos on my 70-300mm tamron lens when the lens is on 300m it wont take the shot, it keeps showing an error message about the contacts and to clean them?

How do i fix this?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

This may or may not be an incorrect error. This error is most likely referring to the contacts between the camera body and the lens. Since you are using an off-brand lens, it is possible that there is a compatibility problem with the communication between the camera and lens. Has that body worked before with that lens under those conditions? If you have another camera body or lens, can the problem be reproduced with a different combination?

If it can be reproduced with a different lens, then the contacts (found around the edge of the lens socket) may in fact need to be cleaned on either the lens or the body or there may be an electrical problem with the camera or lens.

share|improve this answer
    
yes they have worked fine before and i also have the same problem when i use my canon 18mm-55mm lens. @AJHenderson –  leelee21xo Mar 26 '13 at 13:12
    
In that case, it is the contacts on the camera body that are the problem. Try wiping them down with a microfiber cloth with the camera held facing downward (so that any dirt falls out rather than in.) If cleaning them does not work, there could also be an electrical problem with the connection to the contacts. –  AJ Henderson Mar 26 '13 at 13:56

Clean the contacts with a microfiber cloth. They are located on the back of the lens and just inside the lens mount ring on the front of the camera. If that doesn't help, try swapping the battery in your 1100D.

This may or may not solve your problem. Sometimes an older third party lens design like the Tamron AF 70-300mm f/4.0-5.6 Di LD Macro Zoom Lens released in 2006 or the Tamron AF 70-300mm f/4.0-5.6 SP Di VC USD XLD released in 2010 will not be fully compatible with a newer body like the Canon 1100D released in 2011. The reason for this is that is that Canon, like other camera manufacturers, does not share its proprietary design information with competitors. So companies like Tamron have to reverse engineer their lenses to be compatible with the Canon bodies that exist at the time they design the lens. Some lens makers have been known to offer "re-chipping" to bring older lenses up to being compatible with newer bodies, but this has generally involved more expensive lenses than the Tamron 70-300 series.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.