Serene Life

by garik

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

When I open a photo which was in camera upside down, in Canon Digital Photo Professional it is auto rotated to view right way up. But I have not been able to convert and save it this right way up. How do you save this auto correction? Otherwise I seem to be stuck with figuring out what photo to rotate manually, even though auto rotate may have already been done, .... but not saveable????

I am talking about after having downloaded the photos to the computer. The DPP software is in the computer not in the camera.

share|improve this question
    
What camera are you using? I just tried the same thing with my 5DII and Auto rotation only works when the camera is in portrait orientation. –  Michael Clark Mar 8 '13 at 9:49
    
The more information you provide, the easier it will be to find a solution. What camera are you using? What are your in-camera settings for Auto Rotate? What version of DPP are you using? What platform (i.e. Windows 7-64 bit, OS X, etc.) is it installed on? With what program are you viewing the converted/saved images? –  Michael Clark Mar 8 '13 at 10:58
    
I think pipi wants the software to actually apply the rotation and remove the metadata saying to rotate, so that the image will be correctly rotated in software which does not follow the metadata. I don't know of Canon DPP does this, but it could be done in bulk after the fact (and losslessly) by a separate program like jhead. –  mattdm Mar 8 '13 at 13:22

2 Answers 2

I've tried, without success, to reproduce your problem. As a rule I normally have my cameras set to enable auto rotate only when transferred to the computer. In every possible combination of settings I've tried, the convert and save operation displays the image in the orientation DPP was showing it when I converted and saved. Here are some things you might try:

  • Double check that the image is right way up when you view it in DPP. With the several different Canon bodies I have had Auto Rotate only works in portrait mode (when the camera is rotated both left or right) but not when the body is upside down.

  • Update to the latest version of Digital Photo Professional. Currently it is ver. 3.12.52 and can be downloaded from Canon here. If you are already using the most current version try uninstalling and reinstalling the software. Remember the online update requires the disc that came with your camera to be in your optical drive if there is not an older version installed on your machine.

  • Set the Camera to Auto Rotate images only on the computer.

  • If all else fails, you can turn off all Auto Rotate in the camera. Of course you would than need to rotate each image in DPP. You can select all of the images you wish to rotate in the same way and open the edit window. Start the trimming/angle tool. When the first image opens in the trimming/angle window rotate the image to the way you want. Next Press the Copy button and then the Apply All button. This will apply the same changes to all of the selected images without having to do each one individually. Depending on how many images you have selected, it may take a few moments for the program to apply the change to all of the images. Close the trimming/angle window and continue to edit your images as you would like. When you convert and save them they should appear in the same orientation DPP was displaying them.

  • Check any other program you might be using to view the saved and converted files to see if it is set to apply auto rotation. If so, that program may be reading the original auto rotation applied in camera rather than what was changed in DPP.

share|improve this answer

What OS are you running?

If your images are displayed correctly in DPP, then the orientation flag is set correctly.

But if they do not display correctly in Image Viewer in Vista/Win7, that is because the orientation info isn't used by Windows prior to Windows 8

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.