Evening

by w.hrybok

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I'm using a Canon PowerShot A470 for around 3 years. Lately afer switching the camera on, it turns off after a few seconds and a message shows up "replace batteries", even if they new and fully charged. (This camera takes AA batteries.)

I bought new batteries and tried around 5 different kinds of them, all get recognized as empty. How to fix this issue?

share|improve this question

4 Answers 4

(1) This is a guess only - as many people report this problem on the internet increases the possibility.

There may be a power supply filter capacitor that has 'dried out' with age.
One possible solution is to try adding a capacitor across the battery terminals to see what happens. Having a small amount of electronic experience would help. As large a capacitance as is readily available. 1000 uF should be good. 100 uF and up will do no harm. I won't give a detailed how-to as this is reallyt only suitable for who this is enough.

(2) Desperation - may even work. A slightly dear solution, alas. Use "Lithium" AA non rechargeable batteries. These are not cheap. The reason that they MAY work is that they maintain a much flatter voltage across their discharge lifetime, and do not droop under moderate loads for much of their lifetime. 2 x AA Alkaline = 1.65 x 2 when new = 3.3V. This is only at the very start.

(3) Expert only: Use a LiFePO4 (NOT LiIon) battery plus a dummy battery.
A LiFePO4 cell gives up to 3.6V and typically 3.3V down to 3V when operating. SO a single LiFePO4 AA cell will give slightly more voltage and less droop than AA Alkaline batteries.

DO NOT use two LiFePO4 cells in place of 2 x AA Alkaline !!! Use a dummy 0V "cell"

This SHOULD NOT cause damage to the camera, but take due care.

(4) Some people report success after cleaning the battery contacts. Seems unlikely but worth a try.

share|improve this answer

How to fix this issue?

Send the camera in for repair.

share|improve this answer
3  
I suspect that you can get a brand new, probably better, camera for not much more than the repair on an A470 would cost. –  Philip Kendall Mar 5 '13 at 13:22

I keep swapping between 2 pair of batteries, I too have this cam and have the same problem. I know this is a temporary solution but hope this will work.

share|improve this answer
    
OP mentioned that he has swapped 5 pairs, so this solution might not work for OP. –  GoodSp33d Mar 6 '13 at 5:31

Realistically, I think your best option at this point is to invest in a new camera. The A470 wasn't a top-end camera when it was released and it's now 5 years old as well. While it may be possible to squeeze a bit more life out of the camera, it sounds very much like it's on its way out and any money spent on it may not be throwing good money after bad.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.