Serene Life

by garik

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I have been using the Sypder 3 colorimiter and Datacolor Spyder3Elite software to calibrate my screen for several years now. The Sypder3 does wonders, and really improves the quality of my on-screen color representation.

There is one little annoyance, however, and I am curious if anyone else has encountered this. I calibrate my screen to a D50 white point (5000k), as it more closely matches the fine art papers I most often print on. The windows mouse cursor, however, is a very stark, bright white with a tinge of blue (7300k or so), like a glossy photo paper with copious amounts of optical brightener. I'm a little confused as to why my mouse cursor doesn't follow the white point of my monitor's color profile.

Has anyone else encountered this? Is there a way to fix it?

OS: Windows 7 Ultimate

share|improve this question

4 Answers 4

up vote 16 down vote accepted

This has bothered me for years, especially on laptop screens that have no hardware calibration option. Here's an instant fix:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Mouse]
"MouseTrails"="-1"

Save that as a .reg, merge it and then Log Off/On.

With mouse trails enabled windows uses a different render for the cursor which in turn applies the color correction. The original problem is that the ICC profile was not being applied to the mouse cursor and was causing it to "stand out" (read the first post again). WIth this setting, the profile will be applied.

Setting HKCU\Control Panel\Mouse\MouseTrials to -1 turns on mouse trails but sets the trail length to zero. The -1 works on Windows 7 with Nvidia drivers; I have not tested it with other OS/Video combinations.

Possible values for the setting include:

-1 = A buggy setting that seems to enable the cursor trail render but has no actual trails
0  = Off
1  = Also equals off
2  = Lowest you can actually set the trail length in the control panel
10 = Default length
share|improve this answer
    
Mouse Trails is a utility that causes 'ghosting' when moving the cursor around, it was used to make the mouse cursor more visible on old LCD screens. I don't think it would help with the original question. –  Nick Miners Dec 20 '12 at 7:31
    
@Nick: sounds like this exploits a bug (or quirk, at least) to force software rendering of the cursor. Since hardware cursor rendering is a video card feature, this may not work with different drivers, but it's worth a shot. –  mattdm Dec 20 '12 at 12:08
1  
@Quad5NY - thanks for clarifying your answer. Matt - fair enough, I need to calibrate my scepticism default value :) –  Nick Miners Dec 20 '12 at 12:11
    
This is actually the best idea yet for solving the problem with my current screen. I'm saving for an NEC PA271w-bk, a monitor with a true built-in 14-bit LUT for hardware calibration in the screen itself. It is a much better screen than the Apple one I have now, and should solve the problem since it is the screen, rather than windows, that gets calibrated. –  jrista Dec 20 '12 at 16:07
    
@mattdm: I'm not quite sure it's doing software rendering because I loaded up Prime95, 'pegged' both of my CPU's cores to 100% usage and my mouse movements were still smooth. Also when you enable the screen magnifier tool that seems to use the same render (i.e. it applies the profile to the cursor). Nick - No problem, just trying to help. :) –  Quad5Ny Dec 20 '12 at 16:54

Yes, I have a Spyder 2, and I experience the same on all screens that I have calibrated, although not as strongly as you as I calibrate to 6500K. As the mouse cursor is drawn using a hardware sprite rather than drawn as regular graphics, if the graphics hardware supports it, it's not affected by the color profile.

You might consider changing the color temperature of the monitor closer to 5000K before calibrating, if it supports it. That would make the cursor stand out less, and it would also result in a color profile that makes better use of the dynamic range of the monitor.

share|improve this answer
    
+1 on tweaking the monitor to be closer to 5000K. –  Reid Sep 22 '10 at 15:24
    
I have the Apple Cinemadisplay 30". It only has three controls: Backlight +/- and Power. The Spyder3Elite software is very powerful, and it can automatically control many aspects of the screen hardware, including brightness and such. I guess color temp is just one of the things it can't control. –  jrista Sep 22 '10 at 16:08

You don't say what operating system you're using but assuming it's Windows I would recommend using RealWorld Cursor Editor to create yourself a custom cursor.

http://www.rw-designer.com/cursor-maker

It's freeware and will allow you to design a dimmer cursor with a custom colour that will appear white on your monitor. If you're familiar with Photoshop or similar image editing software you'll find it easy to use.

addendum:

It's just occurred to me that if you set the monitor to 5000K (or as close as you can get) using the monitor's own menu before calibrating, the software won't have to shift the colours as much, and the mouse pointer should more closely match the colours being sent for the rest of the desktop!

share|improve this answer
    
I guess I could also just download some cursors. I know there are plenty of free cursor sets on the net. Good idea! –  jrista Sep 22 '10 at 16:09

This is just a guess, but the cursor is often shoveled in by the hardware. It would seem it's not the OS drawing it but something later in the stack of software and hardware that draws the complete screen image, and that something happens after the colors are adjusted to match your calibration. (This is the same reason the cursor often doesn't show up in screenshots.)

In terms of a fix, you could try crafting a copy of the cursor image which is oranger than you want (perhaps photograph the cursor on top of calibrated white to estimate the compensation needed) and set the cursor to that image.

Or, there is a low-vision mode which makes the cursor humongous. Try that for a while, and it will seem so godawful that the normal cursor will be acceptable in comparison. :)

share|improve this answer
1  
HA! +1 for the giant cursor bit. :D Between you and Guffa, I bet the problem is that its rendered by hardware, rather than the OS. Thanks for the tip. –  jrista Sep 22 '10 at 16:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.