Alley in Pisa, Italy

by Lars Kotthoff

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I am importing photos into lightroom (4.3) into date-organized images. I live in +8 timezone. My computer and my cameras are setup correctly (AFAIK).

However, Lightroom consistently imports my images shot in the aftenoon into the next day. That goes for my Canon 7D, my Olympus PEN-2 and my Gopro. I have no idea how to fix this. It seems that Lightroom chooses its own timezone?

Also, this is the same behavior on my PC and my laptop (both windows 7).

additional information

I had now the chance to take this a pit more down to pieces.

  • when I open the import dialogue and hover over an image, the time displayed there is wrong. It is exactly 8 hours later. I am in Hong Kong (+8) and an image taken at 16:01 will be shown to be taken the following day at 00:01. Once I import the images from the camera, the EXIF shows it to be taken at 16:01. This seem weird to me since - if anything - Lightroom should dial the time backwards, not forward since the computer time zone is correctly set at Hong Kong time, and the correct time.
  • I tried that now also with a 5D III with the correct time zone set. Same result.
  • The solution in the link mentioned in the comments does not work. It must be for an old version of Lightroom. There is no such field and no setting for the timezone.
  • when copying the files first to the hard disk and the importing them, everything is correct. While this might be a workaround, this is not really a practicable solution for me. I have a hard time believing that this is intended behavior.
share|improve this question
    
A relevant question: photo.stackexchange.com/questions/21740/… .Could you be more specific on the Lightroom version as "latest version" doesn't mean the same several months from now. As far as I know LR just reads the EXIF date taken and uses that for it's date management. It's behaviour should be independent of the computers timezone. Could you double check that the EXIF info stays the same before and after copying the photos from your memory card? –  Bart Arondson Jan 2 '13 at 17:17
    
I think LR does in fact choose its own time zone, have you checked these options about the metadata? allaboutbalance.com/lightroom-tip-1-adjusting-time-zones –  Sara Munoz Jan 2 '13 at 17:24
2  
"Afternoon" is a pretty wide time range -- can you determine if imports are always off by, say, 8 hours? –  Dan Wolfgang Jan 2 '13 at 19:19
    
@DanWolfgang I determined the time where the jump is for 16:00 HKT. –  uncovery Jan 21 '13 at 14:02
    
@BartArondson The file properties under windows show the images to be taken at 16:01. When I hover over the file in the import dialogue, it shows 00:01 the next day. After importing it, the EXIF shows 16:01 again. –  uncovery Jan 21 '13 at 14:03

2 Answers 2

up vote 6 down vote accepted

As I just found out, this is a bug in Lightroom, more than a year old, but still not fixed. Please see this thread on the support forums where an employee of Adobe confirmed the bug to be linked to the USB connection with the camera. They also recommend to use a card reader instead of the USB connection.

share|improve this answer
    
Good to know. I also never use the USB connection. Card readers are much faster and do not use camera batteries. They are also so cheap I have at 6 of them at the moment! –  Itai Jan 21 '13 at 15:15

Your system clock should be set to the local time. If that is not the case, it has to be fixed since this is how Windows likes to work.

For Lightroom to interpret the time correctly, your camera should be set to the local time as well. IIRC, Canon cameras do not have a concept for timezone or home time.

Assuming both of these issues are corrected, you may want to try to copy your images differently. If you hook the camera directly and import from there, try to copy the files first and then import. While doing so, check to see if the date or time changed as that would hint a problem with the interpretation of the file-system from the source device. That often happens on Windows but on other operating systems as well.

share|improve this answer
1  
Note that the newer Canon cameras do have built in support for time zones, and daylight savings time etc. My 5D3 and Powershot S95 both have it, and with the v2.0 firmware update my 7D got it as well... –  Mike Jan 3 '13 at 11:16
    
@itai The clocks are set correctly, including timezones. The workaround with the copying of files to the HD first works, but I do not know how to fix that "interpretation" of the file-system on the camera. –  uncovery Jan 21 '13 at 14:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.