Spring 2012

Spring 2012
by ani

Submit your Photo
Hall of Fame

Please participate in Meta
and help us grow.

Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently, the autofocus on my Nikon D3100 stopped working. The ring of the lens wouldn't even turn when I tried to focus. However, when switched to manual focus, the camera works fine.

When I used a different lens on the camera, the autofocus would still not work.

Is this fixable? Or do I have to change camera?

share|improve this question
Are you sure you have autofocus turned on on the camera, independently of the lens switch? The rear display should show AF-A, AF-S or AF-C. If it is set to manual, it will show MF. – ElendilTheTall Dec 13 '12 at 17:15
If the lens you are trying on does not have A/M indication in Auto mode you cannot turn the focus ring. Kit lens does not have it. – Recep Dec 14 '12 at 7:11
The D3100 has a settings reset feature - try resetting the settings to get it back to factory default and start from there – Rob Dec 19 '12 at 9:44
Are the photos you are taking while manual focusing ok in terms of brightness? Is your lightmeter working properly? Also is your aperture working properly? If not you have problems about lens coupling elements(diots). In any other case reset the machine to factory settings as Rob said and update the firmware, if the latest update, overwrite the firmware again. – Yiğit Hür Ulaş Feb 6 '13 at 10:18
Try cleaning the electric contacts on the lens mount. – Itai Mar 24 '13 at 14:42

There are multiple possible scenarios here.

  • Lens without internal motor (AF line, including AF-D series and a minority of G-type lenses): Modern low-end cameras can't focus these, even though they can assist you if you enabled the option found in Settings>Rangefinder. You must flip the on-lens switch to M to disconnect the AF coupling gears before the focusing ring will turn (assuming the lens isn't broken!!)

  • Cheapest AF-S lenses (all kit lenses except the 18-105) and old AF-I lenses: Can autofocus on every Nikon DSLR if the focus style in the quick menu (<[i]> button) isn't set to MF. They still feature a traditional focusing ring which is rotated by the motor and thus disabling AF with that option won't enable manual focus unless the mechanics are disengaged via the on-lens switch.

  • Modern mid-grade to high end AF-S lenses: Soft touch, "endless", not-turning-during-AF focusing ring and M/A-M switch: can focus manually in any mode, and automatically if AF is enabled on both the lens and the camera (see above). Rotating the ring during AF operation will stop the motor.

  • AF-S DX VR 18~105:3.5~5.6G ED IF: An odd breed of the previous case where the AF disable switch selects A-M: focus can be adjusted manually at any time but will not cancel motor operation and enable shutter release even after AF fails. It becomes possible for the user to literally fight against the motor (not recommended!)

  • Top of the line AF-S lenses: A combination of the two previous scenarios, with a 3-position focus switch alternating between A/M, M/A and M.

share|improve this answer

Steps to take:

  1. Try a different lens. (You mention that you already have, so that's good.)
  2. Use the camera's "reset to defaults". (See this for Nikon, or your camera's instruction manual.)
  3. Gently clean the electronic contacts on the camera. (Use a very tiny amount of isopropyl alcohol or camera cleaning solution, and cotton swabs meant for this kind of thing.)

If these things don't work, it's time to call the repair shop.

share|improve this answer

The D3100 doesn't have any internal focusing inside, it relies on the Lens internal motor entirely, so if you tried two lenses, the only explanation is that you have disabled focusing in camera sofware. Try resetting the camera to defaults.

share|improve this answer

Check the settings for the AE-L/AF-L button on your camera and make sure you didn't set that to AF-ON as that would remove the ability of the shutter release button to affect autofocus. See page 146 of the manual (English version) for more details on this, but you can also verify this by pressing that button (at the back of the camera, top and to the right of the viewfinder) to see if it focuses, if it does, that's your issue.

As a note, I prefer this setup, it's what I use on my D800.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.