Evening

by w.hrybok

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I'm not a professional at all but bought a Canon Rebel T3i to capture life's moments. The color of my shots are way far off; ie., my sons navy blue and white baseball uniform comes out bright green and red and my walls painted green come out pink. I've read the manual and tried changing the ISO, picture quality, turned the flash on, off....to no avail. The color is even wrong on the LCD in liveview prior to shooting. Can anyone help? Thank you.

share|improve this question
    
When you say "the viewfinder," do you mean the optical viewfinder or the live view on the LCD panel? –  Blrfl Oct 29 '12 at 14:56
    
The live view on the LCD panel. –  Jeannie Oct 29 '12 at 15:01
1  
Can you post an example? That'll help us determine if it's broken or just misconfigured. –  mattdm Oct 29 '12 at 15:37
1  
If it's happening in liveview, it sounds very much like a faulty CCD. Did it just happen? How long have you had the camera for? Are the colours still different when you're not viewing them on the camera itself? –  BBking Oct 29 '12 at 21:15
    
Just clear all setting and check it again. I had some problem with LiveView as well as my pictures. Once I did the complete reset, it fixed the problem. –  Nitin Kumar Oct 31 '12 at 14:45

4 Answers 4

It sounds like your camera's color profile settings may have been screwed with. Canon cameras have a variety of Picture Styles that change the basic white point, saturation, and sharpening according to a few standards. You may also have a range of color temperature settings rated in Kelvins. It is also possible to directly adjust the color balance along blue/yellow and green/magenta axes, which can result in wildly incorrect color.

I would try to set your picture style back to Standard, if it is not already, and see if that fixes things. If that does not work, you might try the Neutral setting. If neither of those work, you will probably need to go into the menu under WB Shift/BKT, and see if you really do have some oddball color balance configuration. You can try resetting that, which should correct any wildly incorrect colors. If that still does not work, you might try resetting your entire camera.

If none of the options above work, then it sounds like something more serious is wrong, and you might need to take your camera in for repair. Canon technical support is astoundingly good, so you shouldn't have a problem getting the support you need. Just be ware it may not be free.

share|improve this answer

Colors cannot be wrong in the viewfinder on any DSLR which includes the Rebel T3i. This is simple physics in that light coming in through the lens is reflected to the viewfinder, so what you see is simply the light that is there. The only way that would not be the case is if you have a colored-filter attached to your lens.

When a picture is taken, the camera by default produces an image based on its Picture Style, Image Parameters applied to the current style and White-Balance. If you are seeing wrong colors every time, you probably screwed with those settings and I advise you Reset your camera from the setup menu. This will bring it to a default sensible state which should give reasonable output under general use.

For what is still wrong, you probably have a problem of Automatic White-Balance. This happens mostly under indoor lighting and when you have scenes dominated by certain colors. Outdoors should rarely be a problem. For example, if you shoot inside and your walls are brightly colored, the camera can give you really weird results. The easiest way to make this better is to select a WB Preset according to the type of lighting you have: Tungsten, Fluorescent, Shade (if not artificial lights are on), etc.

To get white-balance perfect you need to use the camera's Custom White-Balance function with a white-balance card (or other accessory) which is basically an object which is known to be perfectly white. The camera takes a measurement from that and you get colors looking well-balanced. You can even get decent results by using a plain white-sheet of paper.

When you got the camera reset and WB good, you can adjust the Picture Styles to your liking. There are a few styles to start from Standard, Vivid, Natural, etc (the exact list depends on your camera) and each can be adjusted in terms of Saturation, Contrast and possible other parameters (depending on the camera model).

For the exact buttons to press, please refer to the manual which came with your camera. Some camera come with a miniature paper manual in which case you will find the full manual on CD/DVD. Look-up the terms I mentioned and it will be clearly explained.

share|improve this answer
    
I appreciate your answer...but yes, it is on the LCD panel. And it happens outside too. I can take a video to show you if there is a way to post it here. Could I have bought it with such a colored filter? I'm so frustrated trying to fix this problem. –  Jeannie Oct 29 '12 at 15:26
1  
Reset your camera before trying again. It will not erase any of your images, just bring back settings to the manufacturer's default which are reasonable. I doubt you have a colored filter and, if you do, it would be visible at the front of your lens. If you find one just unscrew it until it comes off. For extra peace-of-mind, remove the memory card from the camera before doing the reset. –  Itai Oct 29 '12 at 15:42
    
Thanks for the help. I think I need to bring it somewhere to be fixed. –  Jeannie Oct 29 '12 at 21:05

It does sound like the White Balance is the culprit. Press the Q button go to the WB menu and set it to auto if is something else. I don't think you are doing WB bracketing but you could check that also. Or you could reset the camera settings back to factory settings!

share|improve this answer

While cameras can feature effects and different shooting modes, it's always a good idea to reset the camera if you find you're getting odd results. This should be pretty easy to navigate on any camera. When you've done this, shoot in P (or program mode) and do some test shots.

If you're still getting stuff like:

my sons navy blue and white baseball uniform comes out bright green and red and my walls painted green come out pink.

It's either an LCD fault or a CCD/mainboard problem, does not sound like White Balance at all. A few things to check are:

  • Does it happen in Live View (if the camera supports it)?

Still could be either.

  • Does it happen in the camera's menu?

If colours are fine here, it's likely not the LCD.

  • Look at the shot on the camera, then look at the picture elsewhere. Is there a difference? (and you know the monitor of the secondary source is in working order)

If there isn't, 100% sensor (CCD) problem. If there is a difference, it's LCD or mainboard.

In either case you'll probably have to get it looked at if you've done all the assessing yourself.

The reason I dismissed WB at the start was because it mostly affects reds and blues. Green stays pretty neutral across the warm/cool WB spectrum. Also, "I have pink in my pictures" is a pretty clear indication it's the CCD.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.