Evening

by w.hrybok

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I have my photos on disk and I want to import them into Lightroom.

On each photo I have keyword information in the exif and when I import the files in Lightroom I can see the keywords appear in the keyword bar on the right had side after import.

The problem is that the keywords are imported as only one keyword. For example, if the exif keyword is "beach, europe, sunset" then I expect three keywords in Lightroom namely "beach" "europe" "sunset". Instead in Lightroom there is only one keyword imported which is "beach, europe, sunset". I know that it is one long keyword because I can see it in the keyword list. I have tried with the comma, space and the period as separators with the same result.

My question is what format do I need to use to separate keywords in the exif data before import?

I know I can add keywords during and after import in Lightroom, the reason I want to do this is because I have a separate tool for tagging the photos which I find faster to use.

share|improve this question
1  
The separator is comma on my system but there are options in the Preference -> File Handling dialog to use dot or slash. Try to enable these and see if your separators get recognized. –  Itai Sep 2 '12 at 2:02

1 Answer 1

Try what Itai said, using the Lightroom settings to recognize dot (.) and/or slash(/).

However it should be noted that the exporting application you are using is doing it bad, because the exif information exported should be in a list. This list is what any application will first look for. I think your application only creates a single entry with all the words in it. Using Itai's suggestion should fix this, as Lightroom then will check for a dot or slash.

To illustrate good list:

<keyword>Australia</keyword>
<keyword>2012</keyword>
<keyword>Sunset</keyword>

Bad:

<keyword>Australia, 2012, Sunset</keyword>

To the user all of this should be transparent, and many applications will display all the keywords in the manner "Australia, 2012, Sunset". To say that your application is wrong is a bit dramatic, it has been very common even if today most applications use the "good" way.

Hope this shows why things are happening the way they are. I shall not explain more as it is outside the scope of this forum.

share|improve this answer
    
Thanks, I will try both of these things. The exporting application is using exiftool to add the keywords so I had hoped it would be doing this in a standard way. But I'll try what Itai suggests and see what happens. Thank you both :) –  Rachel Sep 3 '12 at 13:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.