Alley in Pisa, Italy

by Lars Kotthoff

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I have a Cannon Powershot SX20 - it was working fine one day and then the next the LCD screen and image displayed in the view finder were pure white. I can navigate the menus without any trouble and everything seems to be working fine - except everything is pure white. Even in a dark room, with no source of light - the camera shows the same perfectly white image.

If I take a picture it seems to work fine. It saves it to the memory card. But, the picture is pure white.

Can anyone tell me what might be wrong? Seven months ago I paid several hundred dollars to fix a 'spot' that appeared on the lens and caused pictures not to focus correctly. The company that did the 'fix' only warranties their work for six months. But, it did work fine until just yesterday.

I did not drop it or handle it roughly.

share|improve this question
2  
Reset the camera to the factory default if there is an option, and see if that will make any changes to the picture. –  Bill Jul 29 '12 at 18:11
    
There is a 'Reset All...' option - however it is greyed out for reasons unknown to me. I've searched the documentation for the camera but includes nothing about what to do when the Reset All option is greyed out. I've tried with and without the memory card/removing replacing the batteries (including the 'backup battery for the date/time) but it's always greyed out. –  Rob P. Jul 29 '12 at 19:06
    
Maybe everything is already on the default setting. The only thing I can think of, is hardware damage. After the repair did you test the camera? They might forgot to attach a cable here or there. The sensor should not be returning "white" data as you've indicated. –  Bill Jul 29 '12 at 19:20
    
when you try it in a dark room, is it absolutely dark or there's some stray light sneaking in? –  akram Jul 30 '12 at 20:36
    
@AkramMellice - The room is virtually pitch black and the lens cap is on the camera. The screen and the pictures taken are absolutely bright white. There is probably some small amount of light coming from the tiny crack between the floor and the door. –  Rob P. Jul 31 '12 at 11:58
show 1 more comment

2 Answers 2

The camera sensor will be reading the pixels in various amounts of light recieved, however white and black are different in that white is 255,255,255 and black is 0,0,0 across all three colour sensors which means that if no data is recieved either on the sensor or by the cpu from the sensor they will default to white. so either your sensor is broken, the wire to the sensor is broken, or something on the mainboard is broken..

either way, it needs a qualified technician to repair it.

share|improve this answer
add comment

Sounds like you need to take it in to get serviced - the sensor or processing of sensor data is clearly not working correctly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.