Incense

by Bart Arondson

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I have the Problem, that my SD card disappears when I use my Nikon for a while. This means that it suddenly show me a [-E-] instead of the Number of remaining Photos to make.

I don't know if it is a Problem of the camera or if the Card is defect...

Does anybody have any idea what I should do, because it's pretty annoying when I shoot photos and then notice, that the camera/sd-card is bugging again.

Thanks for your help.

share|improve this question
    
What do you do when you notice this, and then what happens? –  mattdm Jul 23 '12 at 13:06
    
I take the sd-card out, and put it back again. and then it works... i noticed the same on the second sd-card slot (with the same sd-card) –  Neifen Jul 23 '12 at 13:14
1  
Have you tried another card? –  mattdm Jul 23 '12 at 13:36

1 Answer 1

First make sure the metal contacts on the card are clean, and reformat the card in the camera using the menu. I assume you've done these things but it doesn't hurt to double check.

Since you get the same behavior in both card slots, it seems likely the card is damaged. They are relatively cheap — get a new one, preferably a higher-end name brand. If you see trouble with another card, send the camera in for cleaning and repair.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.