Time to be with your loved ones

Time to be with loved ones

by sat

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

Recently I've experienced a problem with my D80. I press the trigger and the shutter does not activate.

When I half-press the trigger, the camera seems to auto-focus and auto-expose correctly, and it will AE-AF seem to lock correctly too. However when I press all the way, it won't take a picture. (nothing happens at all, no noises, lights or messages)

I've had it happen in program mode, aperture and shutter priority modes, and even full manual (but without the auto-focus lock happening obviously).

The problem seems to be intermittent. Sometimes this happens on the first shot, sometimes after I have taken several shots in a row, using rapid-fire or spaced single shots. I can't determine an obvious pattern.

It doesn't seem to matter what lens I use or whether I am using my flash gun or the on-board flash, or no flash at all.

For reference the camera is set to AF-C, auto-ISO, capturing in full-sized RAW format.

Is the camera finally wearing out or is something else going on? Can anyone point me to links or reference materials? I tried searching SE-Photography, but I didn't find this specific problem.

share|improve this question
1  
It sounds like your shutter has bitten the dust. You can usually have focal plane shutters like the D80 uses replaced. I would contact Nikon to see what it might take to get a replacement. Should cost a small fraction of the cost of a full replacement camera body. –  jrista Jul 9 '12 at 3:16
    
Could it just be the shutter release switch failing? I'd get a repair estimate. –  RedGrittyBrick Jul 9 '12 at 9:23
    
Have you tried manual focusing? The problem can be that camera cant focus correctly and it won't shot. –  zacharmarz Jul 9 '12 at 9:50
    
May be your D80 is in focus priority mode setup –  von Stein Jul 9 '12 at 18:33
    
@RedGrittyBrick - Manual focusing doesn't seem to cure the issue. It will happen in full manual mode. –  SteveED Jul 10 '12 at 1:18
add comment

1 Answer

up vote 3 down vote accepted

The simplest thing to do, if you have one nearby, is to take it to a Nikon repair/service centre. I've found them to be very helpful. The shutter may need replacing or it might have a bit of dust/grit stuck in it but they'll be able to tell you and price it for you (they may clean up minor issues for free).

share|improve this answer
    
Thanks! I'll look them up. –  SteveED Jul 10 '12 at 1:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.