by ʇolɐǝz ǝɥʇ qoq

Submit your Photo
Hall of Fame

Please participate in Meta
and help us grow.

Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new Canon EOS Kiss camera and a friend of mine has a Sigma Aspherical IF 28-200mm lens she used on an old Canon EOS film camera (old as in 10 years or so). I tried using the lens on my camera. The auto focus worked fine but when I tried to take a picture the camera froze with the following error:

Err 01

Communications between the camera and lens is faulty.
Clean the lens contacts.

I don't think my contacts need cleaning because the camera works fine with a 18-55mm lens.

How can I solve this issue?

share|improve this question

Is it a third-party lens or a Canon one? It is a well known fact that some older Sigma lenses in particular have problems with the electronic interface with newer Canon camera bodies.

share|improve this answer
I know Sigma will sometimes "re-chip" older lenses to work with newer cameras — do you think that might be a possibility here? – mattdm Jun 2 '12 at 14:12
I have no personal experience with this.. I know a lot of people had it done some years ago (I think compatibility was OK with the classic EOS 1D and broke after that, so it has been a while). Don't know if Sigma still offers this service, for such an old lens. If it's a 150 dollar 70-300 piece of junk I doubt it would be worth the effort in any case :) – Staale S Jun 2 '12 at 21:24

I don't think my contacts need cleaning because the camera works fine with a 18-55mm lens.

You could try cleaning the other side of the contact point, that being the contacts on the lens.

share|improve this answer

I have the same lenses and the same problem, but I noticed that if you open the aperture to 5.6 (200mm) you can take photos... you have to fully open the aperture on manual settings. If the size is bigger, you have Error 1.

share|improve this answer

This is old question but problem is still actual on old lenses. What you need is protocol interface which converts aperture change command from camera to lens. Please see my article at this link where is problem cause and it's solution described in detail .

For those who don't want to read whole article I will try to describe problem in short. Old EOS cameras (at moment we can say very old) was using different digital command on SPI bus which tell lens to adjust aperture to some value. For some reason Canon changed that command (old was 0x12 new is 0x13). Result is that your old 3rd party lens is unable to set aperture so gets ERROR 01 because camera cannot set aperture in lens. Solution is easy, add processor to signal path which will convert new command to old one so lens will understand it. See link above for more technical details, HW and SW sources.

share|improve this answer
can you please summarise the content of the link in your answer. Also, are you associated with that site? If so, please disclose. – damned truths Mar 19 '15 at 11:19
Yes I'm author of article on that site, tell me if post should be removed. – j.otisk Mar 20 '15 at 10:34
You need to add that information into your post, including the disclosure. – damned truths Mar 21 '15 at 4:13
Added that information and hoved short description into answer to make it more clear. Thank you for guidance. – j.otisk Mar 22 '15 at 6:59

My lens has the same issue, when i opened it i found that 2 of the ribbon cables were broken... they extend and contract as the internals of the lens moves.

I ordered replacements on ebay cheap, and set to change them, this proves very very difficult, as you must get the very center of the lens and there are about a billion tiny screws, and re-assembly requires perfect alignment. plus soldering the plastic ribbon cable which is super tiny and difficult.

After much dinking around i got it all back together, but not before destroying the set of pins on the collet which makes contact around the edge of the focus ring.

The cables i changed work fine, I know because the shutter is working, and that is the cable i replaced. I'm getting an Error 01 communication, probably due to the focus issues, auto-focus is not working. what I want to try now is to disconnect various aspects of the circuit board until i can use the lense in super manual mode. Any suggestions ?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.