Alley in Pisa, Italy

by Lars Kotthoff

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I've just noticed that whilst shooting with my D5100 using M mode settings reset after each shot. Say, the camera is on a tripod pointing to an object. I've balanced out the exposure to a 0, aperture set to F/8 (this doesn't change btw) and the shutter speed is set to 1/15. I take the picture (camera hasn't moved) and the exposure level and the shutter speed have changed to some random settings (+2 EV exposure and 1/250 shutter speed - it's different every time though). I've searched everywhere, but couldn't find an option that would allow me to save/lock my current settings providing the the image in the view finder doesn't change.

Ideas?

Ta.

share|improve this question
    
I think the other question might benefit from being merged into this one, given that your answer here is the correct one. –  jrista May 7 '12 at 16:25

3 Answers 3

up vote 8 down vote accepted

This behavior is caused by automatic exposure bracketing.

I've had someone with a Nikon D5000 behaving the same way in manual mode, and it turns out that automatic exposure bracketing caused this problem. My Pentax K-5 behaves the same way if the drive mode is set to exposure bracketing in manual exposure mode.

If this does happen to you again, make sure that bracketing is not set and disable it if it is. You do not need to reset the camera to factory defaults.

share|improve this answer
    
Good to know that. Thanks DragonLord! –  Valdas Bycenkovas Apr 26 '12 at 19:21
    
Yep, just tried this and it worked. Disable bracketing and setting stay the same on 'M' - thanks! –  Valdas Bycenkovas May 5 '12 at 17:32
    
@ValdasBycenkovas: Given that this is indeed the correct answer, you might want to switch the "accepted" answer check to this one. –  jrista May 7 '12 at 16:27
    
thanks DragonLord - I had the same problem as Valdas Bycenkovas - it was veru usefull short worth it answer - it works –  user11496 Sep 7 '12 at 23:30

I have a D5100 and I have not seen this happen. As Zak mentioned you may want to try a factory reset. Also are you using the latest firmware for the D5100? The only time I have ever seen anything reset is after the camera turns off, and even then the only thing I have seen reset going from Quick Response Mode for the remote to Single Shot mode. The settings themselves stay the same.

share|improve this answer
    
Thanks! I hesitated to reset it to the factory settings at first for some reason, but then decided to do it anyway and it worked! The settings stay the same for the 2nd, 3rd...etc, pics. Ta muchly! –  Valdas Bycenkovas Apr 23 '12 at 21:21
    
@ValdasBycenkovas - Glad it worked out for you. Good info to know if that ever happens to me. => –  Lynda Apr 23 '12 at 23:32

Exposure safety shift? You should disable this in the setup menu if you do not want the camera to change settings for you.

Usually 1/250 is not a random value but the flash-sync speed, check if you get the same behavior with the flash down, assuming it's up.

share|improve this answer
    
No, i very rarely use the flash and therefore it's closed down pretty much all the time. Also the 1/250 it was just an example, it's different every time. Just tried now: 1st picture exposure 0 EV, F5.6, shutter speed 1/1.6". Took the picture and settings changed to + 2 EV, shutter speed 1/25". Where is the exposure safety shift? Just gone through the whole menu, but couldn't find it... –  Valdas Bycenkovas Apr 23 '12 at 19:22
    
On my Nikon its in custom settings. Maybe it is called something else on the D5100? If all else fail, try a factory reset. –  Zak Apr 23 '12 at 20:26
    
Yep, resetting to the factory settings did the trick. I still wasn't able to find the exposure safety shift, but I think quite simply because it's just not there :) Thanks! –  Valdas Bycenkovas Apr 23 '12 at 21:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.