Summer Start

by VonSchnauzer

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

In Apple Aperture, there are a few unchangeable locations in your library:

  • Projects
  • Photos
  • Faces
  • Places
  • Etc.

And their purpose is pre-defined by the app, so "Photos" should always show all the photos in the current library, regardless of how you tag or organize them. Right?

My "Photos" is now only showing a small sub-set of my pictures. They're all still in the Aperture library, which has ~15,000 pics, but only 854 are showing in photos. And I can tell what they are, roughly. They're one face, which also corresponds to a smart album I have for pics with that face.

But I dont' think I have any filters on. Both the images filter on the lower right and the projects/library filter on the upper left are empty.

Am I missing something obvious? enter image description here

share|improve this question
    
I don't use Aperture. So these are guesses. You are using a Trial - maybe it limits some functionality? Maybe the folders on the left that you put the question mark around, allow duplicates in each folder, and the big library doesn't show duplicates so the total is less? Maybe the folders on the left aren't actually added to the main library, Aperture is just showing what is available on the hard drive? –  dpollitt Mar 16 '12 at 20:12
    
@dpollitt, I'm not actually using a trial; I upgraded shortly after downloading it over a year ago, but was too lazy to rename the library. Thanks, though. –  Jaydles Mar 16 '12 at 21:13

1 Answer 1

up vote 1 down vote accepted

Answer is embarrassing:

Rebulding my library fixed it.

That feels a bit like calling tech support without restarting first, but perhaps my shame can help others.

If you don't know how, here's what you do:

  1. Open Aperture while holding down both Option and Command
  2. You'll see three choices (repair permissions, repair database, rebuild database), and should run them in order from top to bottom. After each one runs, Aperture will open. Close it, and open it again while holding both buttons to run the next one.

If you have other weird stuff, especially related to syncing, I also recommend picking all your pics (click "photos") and going to the Photos menu up top and selecting generate previews.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.