Orquid "Phoenix"

Orquid "Phoenix"

by ceinmart

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I feel like I must be making this harder than it is.

I have an aperture library on my laptop. I use it to import images from my camera. But I don't have much space left on my hard drive so I want to move my images to my external.

On my external drive, I have another library. I realize I may have my setup "wrong", but that is the way it is. The library on my external already has all my images from my iPhoto library so I want to import everything there and have that be my "main" library.

What I need to know is:

1) What is the proper way to import the images such that masters are moved to the external?
2) How do I verify that this is correct (I don't want to delete my images and find out that I was wrong). 3) If I should be doing referenced images all the way, then please explain how I get from where I am, to where I should be.

Every time I import it (and I've tried 3 or 4 times), it either shows that it is referenced or it looks good until I move the images that are on my laptop to the trash can, then they look like they are broken references.

Thank you.

share|improve this question
add comment

2 Answers

Some time ago I moved all my images from my local Mac HD to a network drive, leaving the Lightroom library on the local HD. All I had to do was to move the images to the network drive using the file browser. Once the original files (and their complete directory structure) were on the network drive I opened Lightroom and it showed all the images as broken links. Clicking on a photo in the root folder brought up a dialog informing me that Lightroom could not find the photos and asking if I would like to manually locate them. After manually locating the first photo Lightroom updated the location of all the photos in the same or child directories. So I had to repeat the process for each top level directory but most of the work was done my Lightroom automatically.

share|improve this answer
add comment

Try importing again as you did before. Only after the import go to the "All Images" view in the project navigator, select all your photos and then go up to the menu to find the "consolidate referenced files" menu item. It will pull all of the images into your external library. There should even be an option to let it delete images if you wish.

Make sure everything is backed up first, both internal and external drives!!!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.