Before the rush

Before the rush
by evan-pak

Submit your Photo
Hall of Fame

Please participate in Meta
and help us grow.

Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I attach my phone to lightroom 3 it recognizes the device in the import screen but it does not show any thumbnails as available. When I try to import the images it will not do so and says they are unreadable.

I'm sure I'm missing something (hopefuly obvious) here as to how to do this and would appreciate any help.

Using Mac OS X 10.5.8 latest iPhone software

Thanks for the suggestions

share|improve this question
Please add what version of iOS you are using, as well as the operating system that your computer has to the question. You can edit it to add those details. – dpollitt Jan 11 '12 at 3:57
Really this is a better question for a site like superuser, as the issue likely a software issue with either the iPhone, the computer OS, or file types - and doesn't really pertain to "photography". – dpollitt Jan 11 '12 at 4:05

I have a sort of laundry list of ideas about ways to resolve this.

Most likely issue

The ICC profiles of the images you are trying to import are broken, or marked as "Uncalibrated". Lightroom is having trouble determining exactly what they are, so they need some type of profile embedded before they can be imported. You should be able to open the images in Photoshop or Gimp and embed them with sRGB or similar, then Lightroom can import them without any issues. More info can be found in this thread.

Other potential solutions

It is possible that another application such as iPhoto, iTunes, or Windows "Import Pictures and Video" has the files/folders locked on the iPhone. I would suggest doing a full sync with iTunes, then closing iTunes completely before opening up Lightroom.

I am also wondering what status your iPhone is in, are you in "syncing" mode that was common prior to iOS 5 or are you already disconnected? This would be something to think about if you have an older version of the iOS installed.

Another thing to look at is what type of files you are actually trying to import. It is possible to create all kinds of image files that are not compatible with Lightroom, using apps on the iPhone. Certain image types will appear in Lightroom as "importable", but not give you a preview because they are not fully supported file types.

Example of what you may see with an unsupported file type:


Finally, if you want to try something further, I have read accounts that the following may work: Lightroom Preferences > File Handling tab > Camera Raw Cache Settings > Purge Cache

share|improve this answer
Thanks for all the help..unfortunately none seem to be solution although I have not been able to try the first as I don't have Photoshop or Gimp. Will look further into that option. The image you posted is exactly what i see and the files are all jpegs so that shouldn't be a problem. Thanks again – Davegg Jan 12 '12 at 0:58
I am pretty confident that the 1st option is the most likely fix. I reproduced the issue by removing the ICC profiles of images, and put them on my iPhone. That is how I got the screenshot image :) – dpollitt Jan 12 '12 at 1:44
Thanks again for the help. Do you have any other suggestions on how I can do this without Photoshop or Gimp (not even familiar with that one). I have iPhoto and Lr as my only photo editing software. – Davegg Jan 17 '12 at 15:50
I would suggest doing this in Gimp. Gimp is much like Photoshop, but an open source alternative. It is available for OSX for free. More information about color spaces in Gimp can be found here: If you have more questions, I would suggest opening up a new question about how to embed ICC profiles in Gimp! That would be a good one. Good luck! – dpollitt Jan 17 '12 at 16:35

As described above - but this time with LR5 as it is now 2013 - the device "Seamus's iPhone" was visible, but not its contents - the photo and video files (some of which) I wanted to import.

iTunes appears to lock LR5 out of the Camera Roll on my 'phone. I gather this is a feature of iOS/OS X.

Selection of the "Prevent iPods, iPhones and iPads from syncing automatically" option in iTunes "Devices Preferences" appears to be the solution.

iTunes Preferences Screen Shot

After I disabled this function and closed iTunes, the iOS thumbnails appeared in LR5.

Thank you for the solution dpollitt and others. :)

share|improve this answer

Since you are still on Leopard, I can't be certain that this works the same as Lion, however, I have confirmed that Lightroom 3, on Lion, can see iPhone JPEGS with preview, when the following settings are applied:

If iPhoto or other app opens when you attach the iPhone (not just itunes), it is possible that this is impacting Lightroom's ability to see the files. Do the following:

In Spotlight, type "Image Capture". Click on the Application that comes up called "Image Capture". Attach your iPhone, and select the iPhone in Devices. Then at the bottom left, there is a dialog that says "Connecting this iPhone opens..." choose "No Application". This will mean that iPhoto won't launch when you connect your iPhone, but you can always launch it if you need it.

share|improve this answer
I have tried all the solutions you suggested with no success (was already set up that way). My guess it's a Leopard issue with Lr 3.6 Thanks for your help. – Davegg Jan 12 '12 at 0:59

It's always possible there is some issue with the latest iPhone software (5.0.1) and your version of OS X... 10.5.8 is a few years old now, as the current version is 10.7.2 (Lion).

I would expect Lightroom to be able to read the photos off your iPhone without trouble. Which specific version of Lightroom 3 are you on? 3.6? 3.5?

Can you try importing them into iPhoto and see if you get the same problem?

There is also an app called ImageCapture (I think?) that should be able to just grab the photos off the iPhone without importing them into any workflow software. That way you can just copy them into your folder of choice and see if they can be opened in Preview or the quick view (when you select the file and press Spacebar).

Let me know how you get on.

share|improve this answer
Thanks for the advice unfortunately none of these solutions worked. I have downloaded to iphoto previously but am trying to go into Lr directly (3.6). I used imagecapture and it appeared to download to a folder I created on my desktop but it then appeared empty. Think I may need Lion... – Davegg Jan 12 '12 at 0:51
I don't think Lion is the answer - would appear there is some other issue at play; but without looking directly I could not say what it was. Hope you get it sorted... :) – Mike Jan 12 '12 at 9:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.