Before the rush

Before the rush
by evan-pak

Submit your Photo
Hall of Fame

Please participate in Meta
and help us grow.

Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a temporary catalog for several shoots, but forgot to enable the (IMHO most important and should be enabled by default *shakefist*) check-box in Catalog Settings: Automatically Write Changes to XMP. I edited all the photos from one set and want to move them off my SSD onto my external drive and then import them into another catalog.

The problem is, no XMP files exist after enabling the checkbox.

I first tried selecting every photo, right-clicking -> Metadata -> Save Metadata to File. After a few seconds the process was finished, however only 1/10th of the XMP files were created.

EDIT: Waiting any number of minutes doesn't seem to help.

I also tried to generate 1:1 previews, but that didn't help any.

How can I force Lightroom to "flush" changes to XMP files for every photo?

Note: I would rather not use the export/import catalog feature because a) it takes forever and b) I still need XMP files in case my catalogs are lost/corrupted/etc.

EDIT #2: I can't seem to recreate this problem with Lightroom 4.x.

share|improve this question
3  
There are some known bugs with forced export of XMP sidecar files with Lightroom. I've read a variety of comments on various forums or blogs with people complaining about Lightroom saying its done, but still actually working on exports in the background. Half the time, it also seems to say its done, keep writing .xmp files, but skipping some files for unknown reasons. At the moment, there does not appear to be a fix for this. The alternative would be to convert your raw images to DNG, which stores metadata in the same file. – jrista Dec 14 '11 at 22:03
    
I also have this problem using imported JPEG files. "Include in JPEG" is turned off, "Save XMP" is on. Just wanted to add that this is actually modifying my JPEG files. This is disturbing because I don't have a backup of that file and I thought Lightroom was a non-destructive editor. – Full Decent May 26 at 22:40
    
Also, Catalog Settings -> Reset warnings. This will let you see the rediculousness of Lightroom contradicting itself. Saved here imgur.com/a/UKebT – Full Decent May 26 at 23:08

The answer is very simple. After you check the box with Automatically write changes into XMP, go to menu -> Metadata -> Save metadata to file and you're done.

Even simpler: press Ctrl+S (Mac: Cmd-S).

Note: This only saves metadata for the picture you selected. If you want to create XMP files for all your files, you must go to the Library module, thumbnail view and select all your pictures before you choose Ctrl+S or Save Metadata to file.

share|improve this answer
    
I'm pretty sure this is the same thing as right-clicking on the selected files -> Metadata -> Save Metadata to file. I am trying to reproduce the problem, but no matter which way I do it, XMP export seems to be working (for now). – glenneroo Mar 3 '12 at 12:57

It sounds like you're just trying to write all metadata that is contained within the Lightroom catalog out to a large group of photos. If so, simply select all photos (such as by choosing All Photographs from the left panel in the Library module and then choosing Edit > Select All from the menu), and then choose Metadata > Save Metadata to File from the menu.

This can take a bit of time depending on how many photos you're talking about, but it will write all that information out to the XMP sidecar files. Just keep in mind that membership in Collections and History details are not written out to the XMP file, as that can only be contained within the catalog.

And I totally agree that the Automatically Write Changes to XMP setting is a huge benefit. Just keep in mind that setting is catalog-specific, so you'd need to enable it for any new catalogs.

share|improve this answer
    
Thanks but if you re-read my question, I wrote that I already tried that to minimal avail i.e. about 1/10th of the XMP data actually was written out. – glenneroo Dec 14 '11 at 22:43
    
Are you really sure that all the photos were actually selected? – James Youngman Feb 12 '12 at 15:57
    
Yes. I have even tried selecting just several photos or just one set of photos - all attempts were futile. – glenneroo Feb 20 '12 at 12:50

protected by John Cavan Jul 27 '14 at 1:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.