Forgotten in its old age

by Aditya

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I had the opportunity to use some professional flashes yesterday and I found out that they didn't fire when I was trying to shoot with the camera in Live View mode.

The flashes were two Elinchrom FX400, one wirelessly synchronized with the camera and the other was activated automatically when the first one fired (With a photocell or something).

Using the camera normally fired both flashes at the same time with no issues, but live view mode deactivated both. Why the LV mode is incompatible? Am I missing something?

By the way, I tried this with two cameras, a Canon 1000D and a 550D.

share|improve this question
    
How are you controlling the flashes? What wireless controller is being used? –  ahockley Sep 20 '11 at 22:43
    
@ahockley Uhmmm, not remember, just a very long cable connected to the flash with a black box in the top of it and a remote trigger in the hotshoe of the camera. I think it was generic. But it worked perfectly in non-lv modes! –  Andres Sep 20 '11 at 23:51

2 Answers 2

up vote 4 down vote accepted

Looks like when using a non-Canon flash you can't fire the flash while in live view with a Silent Shooting mode enabled, says the manual:

  • If you use flash, the [Disable] operation will take effect even if you had set it to [Mode 1] or [Mode 2].
  • When using a non-Canon flash unit, set it to [Disable]. (The flash will not fire if [Mode 1] or [Mode 2] is set.)

from http://martybugs.net/blog/blog.cgi/gear/lights/Triggering-Flashes-While-Using-LiveView.html

share|improve this answer

I found out yes you can. Put the camera into multiple frame/burst mode. With your remote take 2 frames, the second frame will activate the flash... it took me AGES to find out how this worked but it does

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.