Road Train !!!!!!!!!!

by Russell McMahon

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

On the same camera body (Canon 1Ds MkII) at the same ISO setting (400) and with no filters attached, two different lenses give the same exposure time (0.4s) at very different apertures. The lenses and the apertures are:

  • Canon 17-40mm L @ F/4
  • Canon 28mm @ F/2.8

Given the differences between the apertures I would expect the exposure times to be different but they are the same. No filters (ND, polarizing etc) were used. How is this possible?

UPDATE:

More data as per your request:

  1. The focal length of the 17-40 was 17 mm, even if through the zoom range the exposure was (almost) the same, including (of course) the value at 28 mm.
  2. The scene was entirely the same (a rather dark one, no bright spots) - no light change, no settings change etc. In fact, I saw this sporadically and I tried to reproduce it. So, the camera was steady, shot a frame at 17 mm, change the lens, shot another one at 28 mm with the prime.
  3. The camera was set up in average metering.
  4. Both lenses were used full open - at F/4 and F/2.8 respectivelly.

TIA for your feedback so far.

share|improve this question
    
What focal length was the 17-40 at?, spot or average metering? –  Tzarium Aug 31 '11 at 10:56
    
Some additional information is required in order to get to a definitive answer: (1) What focal length was the 17-40 lens at? For comparison it should be 28mm. (2) Was the scene you photographed EXACTLY the same in both cases? (No subtle lighting differences, for example.) (3) Were the resulting photos identically exposed? (You imply that they were: can you show us?) (4) Try setting the camera to manual mode and shooting the same scene with each lens, under same light, with ALL settings identical (ISO, aperture & shutter speed). How different are those results? –  Mark Whitaker Aug 31 '11 at 11:10
    
Also (5) What metering mode are you using? Bear in mind that two lenses with different focal lengths are seeing different scenes, and may be metering differently as a result. –  Mark Whitaker Aug 31 '11 at 11:21
1  
for us curious types could you post the pictures with exif? maybe that will shed some light... –  rapscalli Aug 31 '11 at 21:17
1  
@whuber - I think it's still in the realm. If the zoom exposure was slightly darker at that shutter and the prime slightly brighter, than all it really is one rounded down and the other rounded up and landed on the same shutter speed. –  John Cavan Sep 1 '11 at 0:01

4 Answers 4

up vote 5 down vote accepted

The apertures are different, but at only 1 stop I wouldn't call them very different. :)

Anyways, the only other thing that changes in the equation to make the exposure is the amount of light. If you're metering the whole scene then the zoom lens at the wider angle with the smaller aperture metered a larger area and the resulting average indicated the shutter speed. The 28mm, more open, but with a narrower field of view, metered less information and that resulted in less average light.

If you're center metering then you may have metered on a slightly different spot, a darker one, resulting in no change in shutter speed. In any case, it would strike me that the camera has different meter readings based on the scene it has through the lens.

share|improve this answer

0.4 seconds at ISO 400 with fully open lens does sound pretty dark. Perhaps you had some brighter light from rear shining into viewfinder and the camera was metering that one instead? Cover the viewfinder and see if the problem persists.

Next, I suggest you take a RAW photo with each lens at same focal length and export them with same exposure correction setting. If the images are with different brightness, your camera's metering is the trouble spot (perhaps it's too dark for it?); otherwise, it seems for some reason your lenses offer similar light transmission.

If it seems to be the lenses, you might want to try testing what aperture is actually used - could be that your prime doesn't quite open up to f/2.8. You don't need to find the exact value of aperture in each, just if they are different. For that,

  • construct a scene with 2 point light sources at significantly different distances
  • use similar focal length and framing with both lenses
  • focus on one of the lights and shoot (same light with both lenses)
  • on resulting images, compare the diameter of circle projected by out-of-focus light - if it's similar, your lenses were using the same aperture.
share|improve this answer

The F/stop of a lens is not the only characteristic that determines the amount of light it lets through; every lens absorbs a little light, zooms generally more than primes due to the greater number of elements in the lens. The T-stop specifies this light loss, although it is not often given for camera lenses.

A full stop of light seems too much of a difference to be explained by this phenomena.

share|improve this answer

Are you talking about the aperture set on the camera or the maximum aperture on each lens?

They way you present the lens models looks like the difference in apertures is not related to the one used in your test shots (which could indeed be the same). Have you checked the aperture number presented in the camera viewfinder/LCD?

The second lens (28mm) would be able to use a greater aperture (2.8) than the first lens (4.0), but on the test shot they could be both using some other value like 8.0.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.