Alley in Pisa, Italy

by Lars Kotthoff

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

Today I've realized my 70-300 zoom does not rotate fully. In fact, it stops just before the 300 sign is reached in the ring. There's some metallic noise inside the lens when I move it, which let me guess that a mechanical part is broken inside. If I put the lens in vertical position and then I rotate the ring I can reach the 300 sign. Focus works just fine, except when I try to focus when the zoom is stuck before the 300. In that case, the lens moves back and forth as if something is holding it still. I'm going to bring the lens to the Canon customer service, but I'd like to understand what could be wrong, just to be prepared.

Any thought? Oh, I'm not aware of any physical damage to the lens...

share|improve this question

closed as not constructive by Jay Lance Photography, rfusca, jrista Aug 28 '11 at 22:11

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
Hi Roberto, and welcome to PhotoSE. I'm sorry to hear about your lens. I would just like to lend a word of warning, however. Your question, while it could garner some answers, can really be nothing more than speculation, as none of our members can really know what happened to cause the problems you are experiencing. The only people who can truly tell you what went wrong is the Canon repair employees who actually look at and fix your lens. As such, I'm rather inclined to close this as not constructive, as it can't really do much but worry you without good cause. –  jrista Aug 28 '11 at 19:53

1 Answer 1

Without seeing the lens to really diagnose the problem it sounds like something is jamming the zoom mechanism, in any case it'd need to be go back to Canon for repair.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.