Time to be with your loved ones

Time to be with loved ones

by sat

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I'm using Adobe Lightroom 3.0. I go to develop mode and everything is fine (the photo is sharp). After I do any change (saturation, fill light, sharpness... whatever) the photo automatically gets pixelated. In other words, the photo turns into what seems to be a thumbnail enlarged too much — you know the look.

I found that when I zoom in, Lightroom displays "Loading..." and then the photo is once again sharp and in 1:1. I then zoom out, and the photo now displays correctly once again. But if I do any other change, the problem will be repeated.

What's wrong? Anyone have the same problem? I couldn't find a solution anywhere.


[EDIT:] My system: Core 2 Duo @2.33GHz, 2GB ram, Geforce 8800GTS, 7200rpm hdd.

Catalog's Previews folder has 580MB and the catalog.lrcat itself has 24MB. It contains 2070 jpg photos.

The pixelated version (after making a change) The correct version (after zooming in and out)

share|improve this question
    
Can you give some details on the spec of your computer? It sounds like you might be running on and under-powered machine. If you leave it long enough after an edit (without zooming in) does it eventually go sharp again? –  Mark Whitaker Aug 18 '11 at 10:29
    
Is it pixelated when you export it from LR or just in LR? In 1st case I would contact Adobe in 2nd I would upgrade machine or split catalog into smaller chunks. –  Rafal Ziolkowski Aug 18 '11 at 11:11
add comment

3 Answers

First, don't worry: when you 'edit' in Lightroom, you are simply creating a recipe for the program to follow when you tell it to 'Export' or create the image. Until you click 'Export' there is no image. Therefore, the pixelation you see on screen is NOT your image, but is the rendering in memory that LR is doing to show you what the final WILL look like. Don't panic.

I am assuming that you are using RAW images. In this case, LR initially uses the embedded JPEG file to view the image. In order for LR to show you a quality image, it must actually do a RAW conversion under the covers to give you a reasonable image to work with. Until it does, what you get is the embedded JPEG, which is really designed to be a thumbnail. So, until LR renders the preview, you will get a pixelated image.

When you 'Import' into LR, you have the choice to ask LR to render a preview, and what kind of preview. The more detailed, the longer it takes. So standard previews take less time that 1:1. For most, standard previews render quickly, but 1:1 wont render until you try to zoom in. You can ask LR to render all 1:1 immediately if you like.

Also, whenever you make a change in the Develop module, LR updates the preview. However, I believe it uses a different cache: Camera Raw Cache. This one takes the catalog preview image and stores it in the Camera Raw cache and then updates this as you change settings in the Develop module.

I believe one or more of your caches are corrupted. First, try the Develop Module cache, by going into LR Preferences>File Handling. There is a section called "Camera RAW Cache settings". Click the button labeled "Purge Cache".

If this does not work, you can quit LR, navigate to where your LR catalog is stored, and you will find a file called "yourcatalogname Preview.Irdata". Delete this file and restart LR. Then in LR, you can select Library>Previews>Render standard previews, and Library>Previews>Render 1:1 previews.

share|improve this answer
    
Right, every change causes the preview image to have to re-render. With large files, it can take a while, especially for some of the more complicated adjustments like the sharpness tools. I've found the pixelated preview is sufficient for gauging most adjustments (exposure, color, white balance) –  unexplainedBacn Aug 18 '11 at 19:52
    
@cmason Yes I know it's just using copies of the originals (that's great). I using JPG photos! Just one more thing, it's not the 1:1 preview that is pixelated, it's the "fit to window" preview. I need to ask Lightroom the 1:1 preview (by zooming in) to obligate it to generate an correct and updated preview. –  DiAlex Aug 19 '11 at 8:37
    
I purged the cache as you said, but couldn't find the file you mentioned. The closest I have is a folder named "catalogname Previews.lrdata". I didn't delete it though I selected Library>Previews>Render standard previews and it started rendering all the photos (it took a while :P) –  DiAlex Aug 19 '11 at 8:43
    
But the problem remains, please check above two example images. –  DiAlex Aug 19 '11 at 9:46
1  
Standard previews are different from 1:1 previews. It sounds as if your preview cache is somehow corrupt. Delete (or rename/move) your preview cache (yes its the massive one). Then have LR rebuild the cache. From your description however, this sounds like your Camrea RAW cache. However, Camera RAW isn't used (I don't think) for JPEG. So it is likely your 'regular' cache. If this doesn't work, I am stumped, sorry –  cmason Aug 19 '11 at 12:59
show 1 more comment

I have found what is causing it on my computer:

Lightroom was erroneously detecting my overclocked CPU at 0.2 GHz (when it was running at 4.7 GHz). Lightroom apparently forces this pixelated mode when a slow CPU is detected. When I deactivated the overclocking Lightroom correctly detected my CPU at 3.6 GHz and the bug disappeared.

In your case it's possible that your 2.33 GHz is below their cutoff for a "slow CPU". It's also possible that it was a different bug in Lightroom 3.

To check your CPU speed inside Lightroom go to Help -> System Info...

share|improve this answer
add comment

How big is your catalog? I had a similar issue and it was mostly down to having a very large catalog on not a very large machine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.