Forgotten in its old age

by Aditya

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I was going to take pictures of my daughter at the race track, and when I put my lens on my camera (as I have done several times before) this time it was very dark and didn't seem to work properly.

I thought it was something wrong with my camera, and so to check it, I put another lens on it — and it was crystal clear. Is there something I can do to fix it, or is it broken?

share|improve this question
2  
Hi TKF and welcome to the site! Is it 'very dark' or absolutely black? Is your aperture lever stuck or sticky? See this link -photo.blogoverflow.com/files/2011/07/RR_aplever.jpg for a picture - try to slide it a little. –  rfusca Aug 17 '11 at 17:21
1  
Hi TKF! What lens was dark, and which one worked? There are some slight differences between Nikon lenses of different vintages. –  gerikson Aug 17 '11 at 18:28
4  
Is the lens cap attached? –  dpollitt Aug 17 '11 at 19:29
    
Hi and thanks for all the responses @ rfusca it is very dark. I was able to slide the aperture lever.@ gerikson the lens that is dark is of coarse the one I use the most and is AF-S NIKKOR 18-55mm 1:3.5-5.6G. I have used it on numerous occasions and this last time it was really dark. –  TKF Aug 17 '11 at 22:03
1  
@ dpollitt I wish it was only the lens cap being left on. –  TKF Aug 17 '11 at 22:08

3 Answers 3

If its G lens, and the lever isn't stuck - sounds like a busted lens of some kind to me.
Send it in for repair (or for that lens, buy a replacement or upgrade. No time like the present for that 17-55 f/2.8 ;) )

(The only thing I'd try first is to clean the electrical contacts on the lens. If they're not acting right, then it could be telling your camera to stop the aperture down through some odd error.)

share|improve this answer
    
Thank you very much. I will try that first if it dont work then I will have to buy one.. –  TKF Aug 18 '11 at 1:26
    
There's a new 18-55 f/2.8? –  Evan Krall Aug 18 '11 at 4:34
    
@Evan - Ekk, 17-55! Fixed –  rfusca Aug 18 '11 at 5:06

I'd guess that the aperture lever in the lens has been either broken off, or knocked out of alignment. This would mean that if the lens is a G-type lens, it will always be at minimum aperture and the lack of aperture lever will mean it won't be opened up when it's mounted on the camera.

share|improve this answer

One thing to check is the aperture ring (if your lens is not a "G" lens). It should be set to the smallest aperture, say f/22, and then there is a switch (see image, switch with small white dot aligned to orange marking) which will lock it down. If this switch has been bumped, the aperture ring may have moved and the aperture will close down and make the viewfinder dark. Edit: see comments, apparently this is not true!

A dark viewfinder can also be due to a drained battery, but this doesn't seem to be the case with you since another lens worked fine.

aperture ring

share|improve this answer
    
Definitely a thought if it wasnt a G lens, but turns out its the standard G kit lens. –  rfusca Aug 18 '11 at 4:26
1  
Whether you have the aperture at its highest setting or not, the aperture should be fully open in between shots. –  Evan Krall Aug 18 '11 at 4:34
    
Hmmm, I think you're right. Off camera, the aperture would close, but when mounted on the camera, it would be at max aperture. Anyway, it's a G lens, so nevermind anyway! –  MikeW Aug 18 '11 at 4:36

protected by John Cavan Mar 13 at 18:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.