Time to be with your loved ones

Time to be with loved ones

by sat

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I'm having some trouble with the Lightroom viewer (In develop mode) when zoomed out. Look at this picture:

enter image description here

See how the sky seems to have a lot of chroma noise

Now check the zoomed in version (Of the sky part)

enter image description here

I can't see any (significant) chroma noise here!

Finally, check this side by side comparison: Lightroom (RAW original file) and Windows image viewer (Exported JPG, 100 quality) (Click here for the full size version)

enter image description here

The windows image viewer shows a much better sky, without all the "blotches" of color and strong noise that the LR version shows. Do I have something wrongly configured? Do you suffer the same issue?

share|improve this question
1  
Really interesting picture BTW –  Paul Hadfield May 30 '11 at 13:00
    
@Paul Hadfield Thanks, it's the street of my house. Taken with my 550D and a Lensbaby Composer Pro w/ Double Glass. –  Andres May 30 '11 at 13:45
add comment

3 Answers

up vote 5 down vote accepted

I don't use Lightroom but I regularly use Adobe Camera Raw which is pretty much the same thing but built into Photoshop, and have observed the same effect.

By default ACR applies chroma noise reduction to the raw image. The noise reduction only seems to be applied in the preview when you zoom in (perhaps Adobe figured the noise wouldn't be visible in the zoomed out view due to resampling), so what you're seeing in the zoomed out version is the actual noise level, and what you're seeing zoomed in is what it looks like after Lightroom has smoothed the noise.

You could confirm this by turning off noise reduction in Lightroom and seeing if you get the same result zoomed in as zoomed out.

As soon as you export to JPEG the noise reduction is applied to the whole image, which is why you don't see it in the Windows Photo Viewer.

share|improve this answer
1  
Yes, i've observed the same issue with the noise reduction. I can set the slider to 100 and no difference will appear while zoomed out. When zoomed in... it's a completely different image. –  Andres May 27 '11 at 17:29
add comment

To understand what's going on here, it's useful to know a bit about how Lightroom handles your images under the hood.

When you import photos you may notice Lightroom telling you it's generating "previews". These are JPEG images, usually smaller than the full-size image you've imported, which Lightroom generates automatically and stores in its catalog database. It does this because it's subsequently much faster to load one of these JPEGs than to load up your original photo (especially if it's a RAW image) and re-apply all your edits before displaying it. The preview is updated whenever you apply a new edit to a photo, or you can force it to be re-generated from the menu (Library > Previews > ...). Whenever possible (for example, in the Library grid and loupe views), Lightroom will display the faster-loading preview rather than the original RAW image, hence making the experience of browsing through your catalog a bit more slick and responsive.

The blotchy sky you're seeing in the comparison with Windows image viewer is because your previews are set to low or medium quality: this generates smaller JPEGs which load quicker at the expense of some compression artefacts. To fix that, just go to Edit > Catalog Settings... > File Handling and set the preview quality to High. You may want to change it back if you notice this slows Lightroom down appreciably.

I also see the noise issue you've described, and I can always fix it by zooming in to the full-size view of the image (in the Develop module) then back out again. The problem seems to be that the zoomed-out version of the image just update properly when you make noise adjustments.

share|improve this answer
    
I did a 1:1 preview import, zoomed in and out and I can see the same noise and color artifacts. Do you use mac or pc? Nice explanation, btw. –  Andres May 29 '11 at 2:00
    
Thanks Andres. I use a PC. As long as you see the noise corrections when you zoom to 100% you'll be fine: if you export your image from Lightroom (e.g. as a JPEG) those noise corrections will be correctly applied, even if you resize during export. The problem is just caused by Lightroom trying to save time when it creates its preview images. –  Mark Whitaker Jun 5 '11 at 8:34
add comment

This isn't an issue per say, so much as a limitation of Lightroom. The application does not apply noise and/or sharpening settings unless you view images at the 1:1 size representation or higher. That is why they introduced the preview window in the develop module a few revisions back.

At one point there was a workaround that allowed the less than 1:1 size to show the noise settings. If you zoomed into 1:1 then back out, at that time you could see the applied settings. I do not have Lightroom in front of me to test this with the current version. Note, this is only for noise reduction and not for sharpening.

Another workaround would be to switch back from the develop module to the library module. This should display the image as the JPEG output would be displayed, thus running the image through the noise and/or sharpening settings you have in the develop module.

I have read that the limitation is setup this way to improve the speed of the develop module, but I do not believe this is published information from Adobe.

share|improve this answer
    
Nope, zoomming in and then out doesn't show the actual noise reduction (At least in the last version: 3.4) –  Andres May 27 '11 at 19:53
    
Do you have 1:1 previews created on import? That might be part of the equation. –  dpollitt May 27 '11 at 20:09
    
I did a 1:1 preview import and the problem is still present. –  Andres May 29 '11 at 1:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.