Forgotten in its old age

by Aditya

submit your photo


Hall of Fame
View past winners from this year

Please participate in Meta
and help us grow.

Take the 2-minute tour ×
Photography Stack Exchange is a question and answer site for professional, enthusiast and amateur photographers. It's 100% free, no registration required.

I have a Nikon D3100 camera, and am trying to use an "Automatic Fixed Mount Vivitar 200mm lens" with it. When I attach the lens, I get the message "Lens not attached". and nothing works. HELP!

I can't easily take it to a camera shop, as I live in the Mojave Desert, about 200 miles away from any camera shop. This is a new lens, and a new camera.

share|improve this question
1  
Can you be more specific with the model, i.e. max aperture? The current range listed on Vivitar's website doesn't seem to include a 200mm lens. –  ElendilTheTall Apr 30 '11 at 17:31
    
Well I got the T-ring and adapter and had the same problem - no lens attached.. but switched to manual mode and you have to play with the shutter speed and it will take pictures.... –  user14468 Jan 8 '13 at 3:50

3 Answers 3

If this is an older lens, it probably doesn't have the correct contacts (if any) for your D3100 - that camera generally only recognizes much newer lenses. You will probably need to switch to manual mode and will almost certainly not get any metering on your camera.

share|improve this answer
    
+1 I don't think this lens has any electronic contacts at all. –  James May 1 '11 at 12:44

Some things you'll want to try:

  1. Give the contacts on both the lens and the camera body a good cleaning. Rubbing alcohol if you have it, a damp paper towel or rag if you don't... Even spit will work in a pinch if you can live with the 'ick factor.' ;-) (Mojave desert. Yee haw!)
  2. Check to see if any of the contact points on the lens or camera are 'stuck.' Depending on brand, contacts are often spring loaded and designed to move up and down slightly. Occasionally that can mean that a contact point gets stuck so it no longer connects when attaching the lens due to poor manufacturing tolerances, or even a bit of dirt. Use a paperclip (or something paperclip-like) and gently dislodge the contact point. They can be pretty fragile, so you'll want to use as little force as you have to... On occasion over the years I've even simply ran my fingers across the row of contact points and it has been enough to get the stuck contact point to pop back out. Here are a few images identifying the contact point that generally causes the error message.
  3. If you're still getting the error message after trying these things you've kinda exhausted your options for dealing with it yourself and you will want to consider taking it in to a professional who has the tools and knowledge to dig deeper into what is going on with your camera/lens.
share|improve this answer
1  
I want to vote it up...I really do...but you just recommended spit. Spit... man, come on... –  rfusca Apr 30 '11 at 18:56
2  
Hey, if a fella's stuck in the desert... Spit may be all he has! –  Jay Lance Photography Apr 30 '11 at 19:19
    
@rfusca: Happy? ;-) –  Jay Lance Photography Apr 30 '11 at 19:22
1  
@Jay: But...stuck out in the desert...isn't spit the most valuable commodity one has? ;) –  jrista Apr 30 '11 at 19:25
2  
@jrista: No way! The most valuable thing he has is the awesome pictures that he takes! Invest a little spit... Take awesome pictures. That's my motto. ;-) –  Jay Lance Photography Apr 30 '11 at 19:29

Set your camera body to Manual (M). Adjust the shutter speed to what you want, and adjust the aperture on the lens. The camera will fire, and stop down the lens automatically.

You won't get any metering, so you'll need to eyeball the exposure, chimp with the rear screen (enable histogram view), or use an external meter.

There's a group on Flickr dedicated to using manual non-metering lenses on Nikon bodies, you might want to check out their discussions.

One of the nice things about the cheaper Nikon DSLRs, like the D3100, is that you can use some really old Nikkor lenses that lack the AI indexing on the aperture ring. As these lenses are not mountable on newer, more capable Nikons without damaging the body, they can sometimes be found for less money than newer lenses.

share|improve this answer
    
Can you provide some reference for being unable to mount older lenses on "newer, more capable Nikons"? I'd not heard that before. –  rfusca May 1 '11 at 14:31
    
@rfusca The lens compatability chart at Nikonians follows the Nikon manuals and disallows pre-AI lens mounting on the "D40" generation of bodies. However, if you feel like living on the edge, you can trust Ken Rockwell's list. –  gerikson May 1 '11 at 15:17
    
@gerikson - Doesn't that same chart show the giant "No!" for the D3100 also? –  rfusca May 1 '11 at 16:25
    
@rfusca, the Nikonians list is more conservative than Rockwell's. To which one do you refer in your comment? –  gerikson May 1 '11 at 17:15
    
@gerikson Nikonians - I trust Ken about as far as I can throw him. –  rfusca May 1 '11 at 17:26

protected by jrista Jan 21 '13 at 22:00

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.